NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2026-43568 — openclaw

Fix: openclaw/openclaw@6af17b3

CVE-2026-43568 is a CWE-862 vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.

OpenClaw 2026.4.5 through 2026.4.9 - Privilege Escalation via Memory Dreaming Configuration in /dreaming Endpoint

Also known asGHSA-5gjc-grvm-m88j
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-43568.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs12th percentile — riskier than 12% of all scored CVEsHighest risk
0.00%0.29%0.59%0.88%0.0%0.2%Jun 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

133other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
openclawnpm
2.4Mdownloads / week

Description

Summary

Memory dreaming config persistence was reachable from operator.write commands.

Affected Packages / Versions

  • Package: openclaw
  • Ecosystem: npm
  • Affected versions: >= 2026.4.5 < 2026.4.10
  • Patched versions: >= 2026.4.10

Impact

A write-scoped gateway path could toggle persistent memory dreaming settings through /dreaming, crossing into an admin-class configuration mutation.

Technical Details

The fix requires admin scope for persistent dreaming gateway toggles.

Fix

The issue was fixed in #63872. The first stable tag containing the fix is v2026.4.10, and [email protected] includes the fix.

Fix Commit(s)

  • 6af17b39e11f5f35e23b7e5a5f71a7d0aa3c7310
  • PR: #63872

Release Process Note

Users should upgrade to openclaw 2026.4.10 or newer. The latest npm release, 2026.4.14, already includes the fix.

Credits

Thanks to @zpbrent and @zsxsoft, with sponsorship from @KeenSecurityLab and @qclawer for reporting this issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmopenclaw≥ 2026.4.5&&< 2026.4.102026.4.10npm install openclaw@2026.4.10

Affected Products

1 product · 1 configurations
Application
openclawopenclaw
≥ 2026.4.5 && < 2026.4.10
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update openclaw to 2026.4.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-43568 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

## Summary Memory dreaming config persistence was reachable from operator.write commands. ## Affected Packages / Versions - Package: `openclaw` - Ecosystem: npm - Affected versions: `>= 2026.4.5 < 2026.4.10` - Patched versions: `>= 2026.4.10` ## Impact A write-scoped gateway path could toggle persistent memory dreaming settings through `/dreaming`, crossing into an admin-class configuration mutation. ## Technical Details The fix requires admin scope for persistent dreaming gateway toggles. ## Fix The issue was fixed in #63872. The first stable tag containing the fix is `v2026.4.10`, a
O3 Security · Impact-Aware SCA

Is CVE-2026-43568 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-43568: openclaw — Fixed in 2026.4.10