CVE-2026-4270 — awslabs-aws-api-mcp-server
MEDIUMCVE-2026-4270 is a medium-severity (CVSS 5.5) CWE-424 vulnerability in awslabs-aws-api-mcp-server. A fix is available for awslabs-aws-api-mcp-server — see the affected versions and patch details below.
AWS API MCP File Access Restriction Bypass
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-4270.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
awslabs-aws-api-mcp-server🐍awslabs-aws-api-mcp-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Description
The AWS API MCP Server is an open source Model Context Protocol (MCP) server that enables AI assistants to interact with AWS services and resources through AWS CLI commands. It provides programmatic access to manage your AWS infrastructure while maintaining proper security controls.
This server acts as a bridge between AI assistants and AWS services, allowing you to create, update, and manage AWS resources across all available services. The server includes a configurable file access feature that controls how AWS CLI commands interact with the local file system. By default, file operations are restricted to a designated working directory (workdir), but this can be configured to allow unrestricted file system access (unrestricted) or to block all local file path arguments entirely (no-access).
Description: Improper Protection of Alternate Path exists in the no-access and workdir feature of the AWS API MCP Server versions >= 0.2.14 and < 1.3.9 on all platforms may allow the bypass of intended file access restriction and expose arbitrary local file contents in the MCP client application context.
To remediate this issue, users should upgrade to version 1.3.9.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | awslabs-aws-api-mcp-server | ≥ 0.2.14&&< 1.3.9 | 1.3.9pip install --upgrade 'awslabs-aws-api-mcp-server==1.3.9' |
| 🐍PyPI | awslabs-aws-api-mcp-server | ≥ 0.2.14&&< 1.3.9 | 1.3.9pip install --upgrade 'awslabs-aws-api-mcp-server==1.3.9' |
Affected Products
aws api mcp serveramazonDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for awslabs-aws-api-mcp-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update awslabs-aws-api-mcp-server to 1.3.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-4270 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-4270 in your dependencies?
Find it across PyPI, including transitive dependencies.