CVE-2026-42310 — pillow
Fix: python-pillow/Pillow@3bf614eCVE-2026-42310 is a CWE-835 vulnerability in pillow. A fix is available for pillow — see the affected versions and patch details below.
Pillow: PDF Parsing Trailer Infinite Loop (DoS)
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-42310.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
pillowReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
An attacker can supply a malicious PDF that causes the process to hang indefinitely, consuming 100% CPU and making the application unresponsive.
Patches
Patched version: 12.2.0.
PdfParser (introduced in Pillow 4.2.0) follows Prev pointers in PDF trailers to read cross-reference sections. If a trailer's Prev pointer references an offset that has already been processed — either pointing to itself or forming a longer cycle — the parser enters an infinite loop. Pillow now tracks previously processed trailer offsets and raises an error if a cycle is detected.
Workarounds
Use any version but the affected versions: >= 4.2.0, < 12.2.0
Resources
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | pillow | ≥ 4.2.0&&< 12.2.0 | 12.2.0pip install --upgrade 'pillow==12.2.0' |
Affected Products
pillowpythonDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pillow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pillow to 12.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-42310 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat AI Inference Server 3.3 | rhaiis/model-opt-cuda-rhel9:1778244559 | RHSA-2026:16008 |
| Red Hat AI Inference Server 3.3 | rhaiis/vllm-rocm-rhel9:1778244531 | RHSA-2026:16009 |
| Red Hat AI Inference Server 3.3 | rhaiis/vllm-cuda-rhel9:1778274666 | RHSA-2026:16030 |
| Red Hat AI Inference Server 3.4 | rhaii/vllm-spyre-rhel9:1787151840 | RHSA-2026:57387 |
Frequently Asked Questions
Is CVE-2026-42310 in your dependencies?
Find it across PyPI, including transitive dependencies.