CVE-2026-42256 — net-imap
Fix: ruby/net-imap@158d0b5CVE-2026-42256 is a CWE-770 vulnerability in net-imap. A fix is available for net-imap — see the affected versions and patch details below.
net-imap: Denial of service via high iteration count for `SCRAM-*` authentication
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-42256.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
net-imap💎net-imap💎net-imapReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Summary
When authenticating a connection with SCRAM-SHA1 or SCRAM-SHA256, a hostile server can perform a computational denial-of-service attack on the client process by sending a big iteration count value.
Details
A hostile IMAP server can send an arbitrarily large PBKDF2 iteration count in the SCRAM server-first-message, causing the client to perform an expensive OpenSSL::KDF.pbkdf2_hmac call. Because the PBKDF2 function is a blocking C extension and holds onto Ruby’s Global VM Lock, it can freeze the entire Ruby VM for the duration of the computation.
OpenSSL enforces an effective maximum by using a 32-bit signed integer for the iteration count, Depending on hardware capabilities and OpenSSL version, this iteration count may be sufficient for to block all Ruby threads in the process for over seven minutes.
This is listed as one of the "Security Considerations", in RFC 7804:
A hostile server can perform a computational denial-of-service attack on clients by sending a big iteration count value. In order to defend against that, a client implementation can pick a maximum iteration count that it is willing to use and reject any values that exceed that threshold (in such cases, the client, of course, has to fail the authentication).
Impact
During SCRAM authentication to a hostile server, the entire Ruby VM will be locked for the duration of the computation. Depending on hardware capabilities and OpenSSL version, this may take many minutes.
OpenSSL::KDF.pbkdf2_hmac is a blocking C function, so Timeout cannot be used to guard against this. And it retains the Global VM lock, so other ruby threads will also be unable to run.
Mitigation
-
Upgrade to a patched version of
net-imapthat adds themax_iterationsoption to theSASL-*authenticators, and callNet::IMAP#authenticatewith amax_iterationskeyword argument.NOTE: The default
max_iterationsis2³¹ - 1, the maximum signed 32 bit integer, the maximum allowed by OpenSSL. To prevent a denial of service attack, this must be set to a safe value, depending on hardware and version of OpenSSL. It is the user's responsibility to enforce minimum and maximum iteration counts that are appropriate for their security context. -
Alternatively, avoid
SCRAM-*mechanisms when authenticating to untrusted servers.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | net-imap | ≥ 0.6.0&&< 0.6.4 | 0.6.4bundle update net-imap --conservative |
| 💎RubyGems | net-imap | ≥ 0.5.0&&< 0.5.14 | 0.5.14bundle update net-imap --conservative |
| 💎RubyGems | net-imap | ≥ 0.4.0&&< 0.4.24 | 0.4.24bundle update net-imap --conservative |
Affected Products
net\ruby-langDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for net-imap, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update net-imap to 0.6.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-42256 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2026-42256 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | ruby4.0-0:4.0.6-36.el10_2 | RHSA-2026:50773 |
| Red Hat Enterprise Linux 10 | ruby-0:3.3.12-14.el10_2 | RHSA-2026:50778 |
| Red Hat Enterprise Linux 8 | ruby:3.3-8100020260727154509.489197e6 | RHSA-2026:50728 |
| Red Hat Enterprise Linux 9 | ruby:4.0-9080020260727092509.9 | RHSA-2026:50827 |
| Red Hat Enterprise Linux 9 | ruby:3.3-9080020260728061751.9 | RHSA-2026:50828 |
| Red Hat Hardened Images | ruby4-0-main-0.3.2-33.4.hum1 | RHSA-2026:33551 |
| Red Hat Hardened Images | ruby3-4-main-0.3.1-31.2.hum1 | RHSA-2026:33552 |
| Red Hat Hardened Images | ruby3-3-main-0.21.9-23.2.hum1 | RHSA-2026:33721 |
Frequently Asked Questions
Is CVE-2026-42256 in your dependencies?
Find it across RubyGems, including transitive dependencies.