CVE-2026-4202 — redirect-tab
Fix: ayacoo/redirect_tab@085f4cbCVE-2026-4202 is a Information Exposure vulnerability in ayacoo/redirect-tab. A fix is available for ayacoo/redirect-tab — see the affected versions and patch details below.
Broken Access Control in extension "Redirect Tab"
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-4202.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
ayacoo/redirect-tab🐘ayacoo/redirect-tab🐘ayacoo/redirect-tabReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The extension fails to verify, if an authenticated user has permissions to access to redirects resulting in exposure of redirect records when editing a page.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | ayacoo/redirect-tab | all versions | 2.1.2composer require ayacoo/redirect-tab:^2.1.2 |
| 🐘Packagist | ayacoo/redirect-tab | ≥ 3.0.0&&< 3.1.7 | 3.1.7composer require ayacoo/redirect-tab:^3.1.7 |
| 🐘Packagist | ayacoo/redirect-tab | ≥ 4.0.0&&< 4.0.5 | 4.0.5composer require ayacoo/redirect-tab:^4.0.5 |
Affected Products
redirect tabayacooDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ayacoo/redirect-tab, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ayacoo/redirect-tab to 2.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-4202 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2026-4202 in your dependencies?
Find it across Packagist, including transitive dependencies.