Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2026-41840 — spring-webflux

MEDIUM

CVE-2026-41840 is a medium-severity (CVSS 5.9) CWE-401 vulnerability in org.springframework:spring-webflux. A fix is available for org.springframework:spring-webflux — see the affected versions and patch details below.

Spring Framework Denial of Service via Multipart Requests in WebFlux

Published
Updated
Affected
4 pkgs
Patched
2 / 4
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-41840.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk-0.10%
Lower risk than most CVEs19th percentile — riskier than 19% of all scored CVEsHighest risk
0.00%0.29%0.58%0.87%0.2%0.2%0.3%0.4%0.3%Jul 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

CVE-2026-41840 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.

Where this sits among everything scored

Of 397,508 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.

Real-World Exposure

4 pkgs affected
☕org.springframework:spring-webflux☕org.springframework:spring-webflux☕org.springframework:spring-webflux☕org.springframework:spring-webflux

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Spring WebFlux applications are vulnerable to Denial of Service (DoS) attacks when processing multipart requests.

Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.

Affected Packages

4 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework:spring-webflux≥ 7.0.0&&< 7.0.87.0.8org.springframework:spring-webflux:7.0.8
☕Mavenorg.springframework:spring-webflux≥ 6.2.0&&< 6.2.196.2.19org.springframework:spring-webflux:6.2.19
☕Mavenorg.springframework:spring-webflux≥ 6.1.0No fix
☕Mavenorg.springframework:spring-webfluxall versionsNo fix

Affected Products

1 product · 4 configurations
Application
spring frameworkvmware
≥ 7.0.0 && < 7.0.7.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework:spring-webflux, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework:spring-webflux to 7.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-41840 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat ships Spring WebFlux in Fuse 7. The affected version is set to AFFECTED/DEFER as the CVSS score (5.9) is below the 7.0 threshold for immediate remediation.

Workaround published by Red Hat
No specific mitigation is available. Restrict access to multipart request endpoints where possible.
Source: Red Hat security advisory for CVE-2026-41840 (CC BY 4.0)

Frequently Asked Questions

Spring WebFlux applications are vulnerable to Denial of Service (DoS) attacks when processing multipart requests. Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.
O3 Security · Impact-Aware SCA

Is CVE-2026-41840 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-41840: spring-webflux DoS — Fixed in 7.0.8