CVE-2026-41384 — openclaw
Fix: openclaw/openclaw@c2fb7f1CVE-2026-41384 is a CWE-15 vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
OpenClaw < 2026.3.24 - Environment Variable Injection via Workspace Config in CLI Backend
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-41384.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmDescription
Summary
Incomplete Fix for CVE-2026-4039: CLI Backend Environment Variable Injection via Workspace Config
Current Maintainer Triage
- Status: open
- Normalized severity: high
- Assessment: Real shipped malicious-workspace-config env injection in the CLI backend runner, fixed by sanitizing backend env before spawn and shipped in v2026.3.24, so advisory stays open until published.
Affected Packages / Versions
- Package:
openclaw(npm) - Latest published npm version:
2026.3.31 - Vulnerable version range:
<=2026.3.23-2 - Patched versions:
>= 2026.3.24 - First stable tag containing the fix:
v2026.3.24
Fix Commit(s)
c2fb7f1948c3226732a630256b5179a60664ec24— 2026-03-24T12:58:10-07:00
Release Process Note
- The fix is already present in released version
2026.3.24. - This draft looks ready for final maintainer disposition or publication, not additional code-fix work.
Thanks @YLChen-007 for reporting.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | all versions | 2026.3.24npm install openclaw@2026.3.24 |
Affected Products
openclawopenclawDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.3.24 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-41384 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-41384 in your dependencies?
Find it across npm, including transitive dependencies.