NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2026-41248 — @clerk/nextjs

CRITICAL

CVE-2026-41248 is a critical-severity (CVSS 9.1) CWE-436 vulnerability in @clerk/nextjs. A fix is available for @clerk/nextjs — see the affected versions and patch details below.

Official Clerk JavaScript SDKs: Middleware-based route protection bypass

Also known asGHSA-vqx2-fgx2-5wq9
Published
Updated
Affected
11 pkgs
Patched
11 / 11
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-41248.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs25th percentile — riskier than 25% of all scored CVEsHighest risk
0.00%0.34%0.69%1.03%0.1%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

11 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

85other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@clerk/nextjsnpm
3.7Mdownloads / week
@clerk/nuxtnpm
40Kdownloads / week
@clerk/astronpm
46Kdownloads / week

Description

Summary

createRouteMatcher in @clerk/nextjs, @clerk/nuxt, and @clerk/astro can be bypassed by certain crafted requests, allowing them to skip middleware gating and reach downstream handlers.

Sessions are not compromised and no existing user can be impersonated - the bypass only affects the middleware-level gating decision.

Who is affected

All apps using createRouteMatcher should upgrade to the patched versions. Patches are drop-in with no API changes. The information below describes the scope of the bypass and helps you understand whether you are potentially affected, but is not a reason to delay the upgrade.

Apps relying only on middleware gating via createRouteMatcher are affected, because a crafted request can skip middleware checks and reach downstream handlers (API routes, server components, etc.). This middleware pattern permits the bypass:

// Next.js example, equivalent patterns exist in Nuxt and Astro
const isProtectedRoute = createRouteMatcher(['/admin(.*)']);

export default clerkMiddleware(async (auth, req) => {
  if (isProtectedRoute(req)) {
    await auth.protect();
  }
});

That said, the bypass is limited to the middleware-level route-matching gate. clerkMiddleware still authenticates the request and auth() reflects the real authentication state of the caller. Auth checks performed inside your route handlers, server components, or server actions continue to work correctly and are not affected. Whether your app is affected in practice depends on whether you have those downstream checks.

External APIs that authenticate each request with a token are also unaffected on those endpoints, since token verification runs independently.

Additionally, this common middleware pattern correctly blocks the bypass at the middleware layer:

// Next.js example, equivalent patterns exist in Nuxt and Astro
const isPublicRoute = createRouteMatcher(['/docs(.*)']);

export default clerkMiddleware(async (auth, req) => {
  if (!isPublicRoute(req)) {
    await auth.protect();
  }
});

@clerk/shared is usually not imported directly in application code, but if you import createPathMatcher from an affected @clerk/shared version, you are also affected. Run npm why @clerk/shared (or your package manager's equivalent) to check your installed version.

Recommended actions

Install the patched version for your framework (pick the one matching your current major):

@clerk/nextjs

  • v7.x: fixed in 7.2.1
  • v6.x: fixed in 6.39.2
  • v5.x: fixed in 5.7.6

@clerk/nuxt

  • v2.x: fixed in 2.2.2
  • v1.x: fixed in 1.13.28

@clerk/astro

  • v3.x: fixed in 3.0.15
  • v2.x: fixed in 2.17.10
  • v1.x: fixed in 1.5.7

@clerk/shared

  • v4.x: fixed in 4.8.1
  • v3.x: fixed in 3.47.4
  • v2.x: fixed in 2.22.1

Workaround

If you cannot upgrade immediately, adding server-side auth checks (auth()) inside your route handlers, server components, or server actions provides defense-in-depth against this bypass.

Timeline

This issue was reported on 13 APR 2026, patched on 15 APR 2026, and publicly disclosed on 15 APR 2026.

Thanks to Christiaan Swiers for the responsible disclosure of this vulnerability.

Affected Packages

11 total 11 fixed
EcosystemPackageVulnerable rangeFix
📦npm@clerk/nextjs≥ 5.0.0&&< 5.7.65.7.6npm install @clerk/nextjs@5.7.6
📦npm@clerk/nuxt≥ 1.1.0&&< 1.13.281.13.28npm install @clerk/nuxt@1.13.28
📦npm@clerk/astro≥ 0.0.1&&< 1.5.71.5.7npm install @clerk/astro@1.5.7
📦npm@clerk/shared≥ 2.20.17&&< 2.22.12.22.1npm install @clerk/shared@2.22.1
📦npm@clerk/nextjs≥ 6.0.0-snapshot.vb87a27f&&< 6.39.26.39.2npm install @clerk/nextjs@6.39.2
📦npm@clerk/nextjs≥ 7.0.0&&< 7.2.17.2.1npm install @clerk/nextjs@7.2.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @clerk/nextjs, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @clerk/nextjs to 5.7.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-41248 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

## Summary `createRouteMatcher` in `@clerk/nextjs`, `@clerk/nuxt`, and `@clerk/astro` can be bypassed by certain crafted requests, allowing them to skip middleware gating and reach downstream handlers. Sessions are not compromised and no existing user can be impersonated - the bypass only affects the middleware-level gating decision. ## Who is affected All apps using `createRouteMatcher` should upgrade to the patched versions. Patches are drop-in with no API changes. The information below describes the scope of the bypass and helps you understand whether you are potentially affected, but i
O3 Security · Impact-Aware SCA

Is CVE-2026-41248 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-41248: @clerk/nextjs — Fixed in 5.7.6