CVE-2026-41246 — contour
HIGHCVE-2026-41246 is a high-severity (CVSS 8.1) Code Injection vulnerability in github.com/projectcontour/contour. A fix is available for github.com/projectcontour/contour — see the affected versions and patch details below.
Contour: Lua code injection via Cookie Path Rewrite Policy
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-41246.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/projectcontour/contour🐹github.com/projectcontour/contour🐹github.com/projectcontour/contourReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Contour's Cookie Rewriting feature is vulnerable to Lua code injection. An attacker with RBAC permissions to create or modify HTTPProxy resources can craft a malicious value in the following fields that results in arbitrary code execution in the Envoy proxy:
spec.routes[].cookieRewritePolicies[].pathRewrite.valuespec.routes[].services[].cookieRewritePolicies[].pathRewrite.value
The cookie rewriting feature is internally implemented using Envoy's HTTP Lua filter. User-controlled values are interpolated into Lua source code using Go text/template without sufficient sanitization.
The injected code only executes when processing traffic on the attacker's own route, which they already control. However, since Envoy runs as shared infrastructure, the injected code can also:
- Read Envoy's xDS client credentials from the filesystem, which could be used to read all Contour xDS configuration, including TLS certificates and private keys of other tenants.
- Cause denial of service for other tenants sharing the Envoy instance.
Other use cases of Lua filter are not vulnerable.
Patches
The fix is available in Contour v1.33.4, v1.32.5, and v1.31.6.
- v1.33.4: User-provided values are no longer interpolated into Lua code. Use of
text/templateis removed. Requires Envoy 1.35.0 or later. - v1.32.5, v1.31.6: User-provided values are escaped before interpolation into Lua code.
Workarounds
There are no workarounds. Users should upgrade to a patched version.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/projectcontour/contour | ≥ 1.19.0&&< 1.31.6 | 1.31.6go get github.com/projectcontour/contour@v1.31.6 |
| 🐹Go | github.com/projectcontour/contour | ≥ 1.32.0&&< 1.32.5 | 1.32.5go get github.com/projectcontour/contour@v1.32.5 |
| 🐹Go | github.com/projectcontour/contour | ≥ 1.33.0&&< 1.33.4 | 1.33.4go get github.com/projectcontour/contour@v1.33.4 |
Affected Products
contourprojectcontourDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/projectcontour/contour, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/projectcontour/contour to 1.31.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-41246 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2026-41246 in your dependencies?
Find it across Go, including transitive dependencies.