CVE-2026-40979 — spring-ai-transformers
MEDIUMCVE-2026-40979 is a medium-severity (CVSS 6.1) CWE-377 vulnerability in org.springframework.ai:spring-ai-transformers. A fix is available for org.springframework.ai:spring-ai-transformers — see the affected versions and patch details below.
Spring AI's ONNX model cache defaults to world-writable predictable /tmp directory
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-40979.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.springframework.ai:spring-ai-transformers☕org.springframework.ai:spring-ai-transformersReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Spring AI, having access to a shared environment can expose the ONNX model used by the application.
Affected versions: Spring AI: 1.0.0 - 1.0.5 (fixed in 1.0.6), 1.1.0 - 1.1.4 (fixed in 1.1.5)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.springframework.ai:spring-ai-transformers | ≥ 1.0.0&&< 1.0.6 | 1.0.6org.springframework.ai:spring-ai-transformers:1.0.6 |
| ☕Maven | org.springframework.ai:spring-ai-transformers | ≥ 1.1.0&&< 1.1.5 | 1.1.5org.springframework.ai:spring-ai-transformers:1.1.5 |
Affected Products
spring aivmwareDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.ai:spring-ai-transformers, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.springframework.ai:spring-ai-transformers to 1.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-40979 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-40979 in your dependencies?
Find it across Maven, including transitive dependencies.