CVE-2026-40967 — spring-ai-vector-store
HIGHCVE-2026-40967 is a high-severity (CVSS 8.6) Code Injection vulnerability in org.springframework.ai:spring-ai-vector-store. A fix is available for org.springframework.ai:spring-ai-vector-store — see the affected versions and patch details below.
Spring AI has a VectorStore FilterExpression Converter injection
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-40967.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.springframework.ai:spring-ai-vector-store☕org.springframework.ai:spring-ai-vector-storeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Spring AI, various FilterExpressionConverter implementations accept a filter expression object and translate them to specific vector store query languages. In several cases, keys and values are not properly escaped, leading to the ability to alter the query.
Affected versions: Spring AI: 1.0.0 - 1.0.5 (fixed in 1.0.6), 1.1.0 - 1.1.4 (fixed in 1.1.5)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.springframework.ai:spring-ai-vector-store | ≥ 1.0.0&&< 1.0.6 | 1.0.6org.springframework.ai:spring-ai-vector-store:1.0.6 |
| ☕Maven | org.springframework.ai:spring-ai-vector-store | ≥ 1.1.0&&< 1.1.5 | 1.1.5org.springframework.ai:spring-ai-vector-store:1.1.5 |
Affected Products
spring aivmwareDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.ai:spring-ai-vector-store, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.springframework.ai:spring-ai-vector-store to 1.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-40967 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2026-40967 in your dependencies?
Find it across Maven, including transitive dependencies.