NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2026-40966 — spring-ai-advisors-vector…

MEDIUM

CVE-2026-40966 is a medium-severity (CVSS 5.9) CWE-284 vulnerability in org.springframework.ai:spring-ai-advisors-vector-store. A fix is available for org.springframework.ai:spring-ai-advisors-vector-store — see the affected versions and patch details below.

VectorStoreChatMemoryAdvisor conversation scoping can lead to cross-tenant memory exfiltration

Also known asGHSA-v6x6-pjxw-3pv2
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-40966.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs14th percentile — riskier than 14% of all scored CVEsHighest risk
0.00%0.29%0.58%0.87%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.springframework.ai:spring-ai-advisors-vector-store☕org.springframework.ai:spring-ai-advisors-vector-store

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Spring AI, an attacker can bypass conversation isolation and exfiltrate sensitive memory from other users’ chat histories, including secrets and credentials, by injecting filter logic through conversationId. Only applications that use VectorStoreChatMemoryAdvisor and pass user-supplied input as a conversationId are affected.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework.ai:spring-ai-advisors-vector-store≥ 1.0.0&&< 1.0.61.0.6org.springframework.ai:spring-ai-advisors-vector-store:1.0.6
☕Mavenorg.springframework.ai:spring-ai-advisors-vector-store≥ 1.1.0&&< 1.1.51.1.5org.springframework.ai:spring-ai-advisors-vector-store:1.1.5

Affected Products

1 product · 2 configurations
Application
spring aivmware
≥ 1.1.0 && < 1.1.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.ai:spring-ai-advisors-vector-store, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework.ai:spring-ai-advisors-vector-store to 1.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-40966 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

In Spring AI, an attacker can bypass conversation isolation and exfiltrate sensitive memory from other users’ chat histories, including secrets and credentials, by injecting filter logic through conversationId. Only applications that use VectorStoreChatMemoryAdvisor and pass user-supplied input as a conversationId are affected.
O3 Security · Impact-Aware SCA

Is CVE-2026-40966 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-40966: spring-ai-advisors-vector… — Fixed in 1.0.6