# CVE-2026-40477: thymeleaf — Fix Available

☕

☕ Maven

Not in CISA KEV

CRITICAL severity

# CVE-2026-40477 — thymeleaf

CRITICAL 

CVE-2026-40477 is a critical-severity (CVSS 9) Expression Language Injection vulnerability in org.thymeleaf:thymeleaf. A fix is available for org.thymeleaf:thymeleaf — see the affected versions and patch details below.

Improper restriction of the scope of accessible objects in Thymeleaf expressions

Also known as[GHSA-r4v4-5mwr-2fwr](/vulnerability/GHSA-r4v4-5mwr-2fwr)

Published

Apr 17, 2026

Updated

Oct 28, 2026

Affected

3 pkgs

Patched

3 / 3

Exploits

None indexed

Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

## Exploitation Status

### No confirmed exploitation observed yet

-   A successful exploit gives an attacker total control of the affected component, not partial access.
-   CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-40477.

## EPSS Exploitation Probability

[via FIRST.org ↗](https://www.first.org/epss/)

0.9%probability of exploitation in next 30 days

Lower Risk0.00%

Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk

0.00%0.48%0.96%1.44%0.1%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from [FIRST.org EPSS](https://www.first.org/epss/).

## How urgent is this, really

## Where this sits among everything scored

## Real-World Exposure

3 pkgs affected

☕`org.thymeleaf:thymeleaf`☕`org.thymeleaf:thymeleaf-spring5`☕`org.thymeleaf:thymeleaf-spring6`

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

## Description

#### Impact

A security bypass vulnerability exists in the expression execution mechanisms of Thymeleaf up to and including 3.1.3.RELEASE. Although the library provides mechanisms to prevent expression injection, it fails to properly restrict the scope of accessible objects, allowing specific potentially sensitive objects to be reached from within a template. If an application developer passes unvalidated user input directly to the template engine, an unauthenticated remote attacker can bypass the library's protections to achieve Server-Side Template Injection (SSTI).

#### Patches

This has been fixed in Thymeleaf 3.1.4.RELEASE.

#### Workarounds

No workaround is available beyond ensuring applications do not pass unvalidated user input directly to the template engine. Upgrading to 3.1.4.RELEASE is strongly recommended in any case.

#### Credits

Thanks to Thomas Reburn (Praetorian) for responsible disclosure.

## Affected Packages

3 total 3 fixed

Ecosystem

Package

Vulnerable range

Fix

☕Maven

`org.thymeleaf:thymeleaf` 

all versions

3.1.4.RELEASE`org.thymeleaf:thymeleaf:3.1.4.RELEASE`

☕Maven

`org.thymeleaf:thymeleaf-spring5` 

all versions

3.1.4.RELEASE`org.thymeleaf:thymeleaf-spring5:3.1.4.RELEASE`

☕Maven

`org.thymeleaf:thymeleaf-spring6` 

all versions

3.1.4.RELEASE`org.thymeleaf:thymeleaf-spring6:3.1.4.RELEASE`

## Affected Products

1 product · 1 configurations

Application

`thymeleaf`thymeleaf

< 3.1.4

range

## Detection & mitigation playbook

Open-source dependency

1.  ### Detect
    
    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.thymeleaf:thymeleaf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
    
2.  ### Fix
    
    Update org.thymeleaf:thymeleaf to 3.1.4.RELEASE or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-40477 is resolved across your whole dependency graph.
    
3.  ### Workarounds
    
    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
    

## Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

Workaround published by Red Hat

> Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.

Source: [Red Hat security advisory for CVE-2026-40477](https://access.redhat.com/security/cve/cve-2026-40477) (CC BY 4.0)

Product

Fixed in

Advisory

Red Hat OpenShift Dev Spaces 3.28

`devspaces/openvsx-rhel9:1779528224`

[RHSA-2026:21772](https://access.redhat.com/errata/RHSA-2026:21772)

## Frequently Asked Questions

\### Impact A security bypass vulnerability exists in the expression execution mechanisms of Thymeleaf up to and including 3.1.3.RELEASE. Although the library provides mechanisms to prevent expression injection, it fails to properly restrict the scope of accessible objects, allowing specific potentially sensitive objects to be reached from within a template. If an application developer passes unvalidated user input directly to the template engine, an unauthenticated remote attacker can bypass the library's protections to achieve Server-Side Template Injection (SSTI). ### Patches This has been

O3 Security · Impact-Aware SCA

### Is CVE-2026-40477 in your dependencies?

Find it across Maven, including transitive dependencies.

[Scan my dependencies](/book-demo) [How O3 SCA works](/impact-aware-sca)