CVE-2026-33884 — cms
MEDIUMCVE-2026-33884 is a medium-severity (CVSS 4.3) CWE-863 vulnerability in statamic/cms. A fix is available for statamic/cms — see the affected versions and patch details below.
Statamic's live preview token bypasses content protection for unrelated entries
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-33884.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
statamic/cms🐘statamic/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Statamic is a Laravel and Git powered content management system (CMS). Prior to versions 5.73.16 and 6.7.2, an authenticated Control Panel user with access to live preview could use a live preview token to access restricted content that the token was not intended for. This has been fixed in 5.73.16 and 6.7.2.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | statamic/cms | all versions | 5.73.16composer require statamic/cms:^5.73.16 |
| 🐘Packagist | statamic/cms | ≥ 6.0.0-alpha.1&&< 6.7.2 | 6.7.2composer require statamic/cms:^6.7.2 |
Affected Products
statamicstatamicDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for statamic/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update statamic/cms to 5.73.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-33884 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2026-33884 in your dependencies?
Find it across Packagist, including transitive dependencies.