CVE-2026-33750 is a medium-severity (CVSS 6.5) Uncontrolled Resource Consumption vulnerability in brace-expansion. A fix is available for brace-expansion — see the affected versions and patch details below.
brace-expansion: Zero-step sequence causes process hang and memory exhaustion
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-33750.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
brace-expansionnpmDescription
Impact
A brace pattern with a zero step value (e.g., {1..2..0}) causes the sequence generation loop to run indefinitely, making the process hang for seconds and allocate heaps of memory.
The loop in question:
test() is one of
The increment is computed as Math.abs(0) = 0, so the loop variable never advances. On a test machine, the process hangs for about 3.5 seconds and allocates roughly 1.9 GB of memory before throwing a RangeError. Setting max to any value has no effect because the limit is only checked at the output combination step, not during sequence generation.
This affects any application that passes untrusted strings to expand(), or by error sets a step value of 0. That includes tools built on minimatch/glob that resolve patterns from CLI arguments or config files. The input needed is just 10 bytes.
Patches
Upgrade to versions
- 5.0.5+
A step increment of 0 is now sanitized to 1, which matches bash behavior.
Workarounds
Sanitize strings passed to expand() to ensure a step value of 0 is not used.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | brace-expansion | ≥ 4.0.0&&< 5.0.5 | 5.0.5npm install brace-expansion@5.0.5 |
| 📦npm | brace-expansion | ≥ 3.0.0&&< 3.0.2 | 3.0.2npm install brace-expansion@3.0.2 |
| 📦npm | brace-expansion | ≥ 2.0.0&&< 2.0.3 | 2.0.3npm install brace-expansion@2.0.3 |
| 📦npm | brace-expansion | all versions | 1.1.13npm install brace-expansion@1.1.13 |
Affected Products
brace-expansionjuliangruberDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for brace-expansion, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update brace-expansion to 5.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-33750 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability has been rated as Moderate by Red Hat. The vulnerability requires parsing a malformed pattern that, when parsed, leads to infinite looping, excessive memory allocation, and could result in a DoS. The flaw is rated as Moderate because the vulnerable code in the brace-expansion library is not exposed…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Openshift Data Foundation 4.18 | odf4/cephcsi-rhel9:1786705347 | RHSA-2026:56431 |
| Red Hat Openshift Data Foundation 4.22 | odf4/cephcsi-rhel9:1787057250 | RHSA-2026:56928 |
Frequently Asked Questions
Is CVE-2026-33750 in your dependencies?
Find it across npm, including transitive dependencies.