NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2026-33718 — openhands-ai

HIGHFix: OpenHands/OpenHands#13051

CVE-2026-33718 is a high-severity (CVSS 7.6) OS Command Injection vulnerability in openhands-ai. A fix is available for openhands-ai — see the affected versions and patch details below.

OpenHands is Vulnerable to Command Injection through its Git Diff Handler

Also known asGHSA-7h8w-hj9j-8rjwPYSEC-2026-106
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-33718.

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.00%1.29%2.59%3.88%0.2%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍openhands-ai

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Summary

A Command Injection vulnerability exists in the get_git_diff() method at openhands/runtime/utils/git_handler.py:134. The path parameter from the /api/conversations/{conversation_id}/git/diff API endpoint is passed unsanitized to a shell command, allowing authenticated attackers to execute arbitrary commands in the agent sandbox. The user is already allowed to instruct the agent to execute commands, but this bypasses the normal channels.


Details

Vulnerable Code Path

The vulnerability flows through these files:

  1. API Endpoint (openhands/server/routes/files.py:267-277)
@app.get('/git/diff')
async def git_diff(
    path: str,  # <-- User input from HTTP request
    ...
):
    ...
    diff = await call_sync_from_async(runtime.get_git_diff, path, cwd)  # No sanitization
  1. Runtime (openhands/runtime/base.py:1231-1233)
def get_git_diff(self, file_path: str, cwd: str) -> dict[str, str]:
    self.git_handler.set_cwd(cwd)
    return self.git_handler.get_git_diff(file_path)  # Passed directly
  1. Vulnerable Method (openhands/runtime/utils/git_handler.py:10-12, 134)
# Command template with placeholder
GIT_DIFF_CMD = 'python3 /openhands/code/openhands/runtime/utils/git_diff.py "{file_path}"'

# Line 134 - VULNERABLE: User input directly interpolated
result = self.execute(self.git_diff_cmd.format(file_path=file_path), self.cwd)
  1. Shell Execution (openhands/runtime/utils/git_diff.py:25-27)
def run(cmd: str, cwd: str) -> str:
    result = subprocess.run(
        args=cmd,
        shell=True,  # <-- Enables shell metacharacter interpretation
        stdout=subprocess.PIPE,
        stderr=subprocess.PIPE,
        cwd=cwd
    )

Root Cause

The file_path parameter is directly interpolated into a shell command string using Python's .format() method without any sanitization. When this command is executed with shell=True, shell metacharacters like ", ;, and # are interpreted, allowing command injection.

Example:

  • Input: test"; id #
  • Constructed command: python3 /script.py "test"; id #"
  • Shell interprets as two commands: python3 /script.py "test" AND id

Impact

Who is Affected

  • All OpenHands deployments exposing the /api/conversations/{id}/git/diff endpoint
  • Any authenticated user can exploit this vulnerability,

Attack Capabilities

An attacker can:

  1. Execute arbitrary commands on the runtime container as root
  2. Read sensitive files including .env, API keys, source code
  3. Write arbitrary files to inject malicious code
  4. Establish reverse shells for persistent access
  5. Potentially escape the container if Docker is misconfigured

Mitigation

Users should update to the latest version of OpenHands that includes the changes from PR #13051. The fix replaces direct shell string formatting with proper argument array handling or rigorous path sanitization to prevent command chaining.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIopenhands-aiall versions1.5.0pip install --upgrade 'openhands-ai==1.5.0'

Affected Products

1 product · 1 configurations
Application
openhandsopenhands
< 1.5.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openhands-ai, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update openhands-ai to 1.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-33718 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

## Summary A Command Injection vulnerability exists in the `get_git_diff()` method at `openhands/runtime/utils/git_handler.py:134`. The `path` parameter from the `/api/conversations/{conversation_id}/git/diff` API endpoint is passed unsanitized to a shell command, allowing authenticated attackers to execute arbitrary commands in the agent sandbox. The user is already allowed to instruct the agent to execute commands, but this bypasses the normal channels. --- ## Details ### Vulnerable Code Path The vulnerability flows through these files: 1. **API Endpoint** (`openhands/server/routes/fil
O3 Security · Impact-Aware SCA

Is CVE-2026-33718 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2026-33718: openhands-ai — Fixed in 1.5.0