NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2026-33713 — n8n

CVE-2026-33713 is a SQL Injection vulnerability in n8n. A fix is available for n8n — see the affected versions and patch details below.

n8n Vulnerable to SQL Injection in Data Table Node via orderByColumn Expression

Also known asGHSA-98c2-4cr3-4jc3
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-33713.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs37th percentile — riskier than 37% of all scored CVEsHighest risk
0.00%0.35%0.69%1.04%0.0%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

3 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

36other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
n8nnpm
131Kdownloads / week

Description

n8n is an open source workflow automation platform. Prior to versions 2.14.1, 2.13.3, and 1.123.26, an authenticated user with permission to create or modify workflows could exploit a SQL injection vulnerability in the Data Table Get node. On default SQLite DB, single statements can be manipulated and the attack surface is practically limited. On PostgreSQL deployments, multi-statement execution is possible, enabling data modification and deletion. The issue has been fixed in n8n versions 1.123.26, 2.13.3, and 2.14.1. Users should upgrade to one of these versions or later to remediate the vulnerability. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only, disable the Data Table node by adding n8n-nodes-base.dataTable to the NODES_EXCLUDE environment variable, and/or review existing workflows for Data Table Get nodes where orderByColumn is set to an expression that incorporates external or user-supplied input. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
📦npmn8nall versions1.123.26npm install n8n@1.123.26
📦npmn8n≥ 2.14.0&&< 2.14.12.14.1npm install n8n@2.14.1
📦npmn8n≥ 2.0.0-rc.0&&< 2.13.32.13.3npm install n8n@2.13.3

Affected Products

1 product · 3 configurations
Application
n8nn8n
≥ 2.0.0 && < 2.13.3
1 version
2.14.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for n8n, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update n8n to 1.123.26 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-33713 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

n8n is an open source workflow automation platform. Prior to versions 2.14.1, 2.13.3, and 1.123.26, an authenticated user with permission to create or modify workflows could exploit a SQL injection vulnerability in the Data Table Get node. On default SQLite DB, single statements can be manipulated and the attack surface is practically limited. On PostgreSQL deployments, multi-statement execution is possible, enabling data modification and deletion. The issue has been fixed in n8n versions 1.123.26, 2.13.3, and 2.14.1. Users should upgrade to one of these versions or later to remediate the vuln
O3 Security · Impact-Aware SCA

Is CVE-2026-33713 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-33713: n8n SQL Injection — Fixed in 1.123.26