CVE-2026-33430 is a high-severity (CVSS 7.3) CWE-732 vulnerability in briefcase. A fix is available for briefcase — see the affected versions and patch details below.
Briefcase: Windows MSI Installer Privilege Escalation via Insecure Directory Permissions
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-33430.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
briefcaseReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
If a developer uses Briefcase to produce an Windows MSI installer for a project, and that project is installed for All Users (i.e., per-machine scope), the installation process creates an directory that inherits all the permissions of the parent directory. Depending on the location chosen by the installing user, this may allow a low privilege but authenticated user to replace or modify the binaries installed by the application. If an administrator then runs the altered binary, the binary will run with elevated privileges.
Patches
The problem is caused by the template used to generate the WXS file for Windows projects. It was fixed with the following PRs:
- beeware/briefcase-windows-app-template#86
- beeware/briefcase-windows-VisualStudio-template#85
These patches have been backported to the templates used in Briefcase 0.3.26, 0.4.0, and 0.4.1. Re-running briefcase create on your Briefcase project will result in the updated templates being used.
Workarounds
The change from beeware/briefcase-windows-app-template#86 can be added to any existing Briefcase .wxs file generated by Briefcase 0.3.24 or later.
Resources
beeware/briefcase#2759 is a formal bug report of the problem.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | briefcase | ≥ 0.3.0&&< 0.3.26 | 0.3.26pip install --upgrade 'briefcase==0.3.26' |
Affected Products
briefcasebeewareDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for briefcase, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update briefcase to 0.3.26 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-33430 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-33430 in your dependencies?
Find it across PyPI, including transitive dependencies.