CVE-2026-33172 — cms
HIGHCVE-2026-33172 is a high-severity (CVSS 8.7) Cross-site Scripting (XSS) vulnerability in statamic/cms. A fix is available for statamic/cms — see the affected versions and patch details below.
Statamic has Stored XSS via SVG Sanitization Bypass
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-33172.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
statamic/cms🐘statamic/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Statamic is a Laravel and Git powered content management system (CMS). Prior to versions 5.73.14 and 6.7.0, a stored XSS vulnerability in SVG asset reuploads allows authenticated users with asset upload permissions to bypass SVG sanitization and inject malicious JavaScript that executes when the asset is viewed. This has been fixed in 5.73.14 and 6.7.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | statamic/cms | ≥ 6.0.0-alpha.1&&< 6.7.0 | 6.7.0composer require statamic/cms:^6.7.0 |
| 🐘Packagist | statamic/cms | all versions | 5.73.14composer require statamic/cms:^5.73.14 |
Affected Products
statamicstatamicDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for statamic/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update statamic/cms to 6.7.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-33172 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2026-33172 in your dependencies?
Find it across Packagist, including transitive dependencies.