CVE-2026-32766 — astral-tokio-tar
Fix: astral-sh/tokio-tar@e5e0139CVE-2026-32766 is a CWE-436 vulnerability in astral-tokio-tar. A fix is available for astral-tokio-tar — see the affected versions and patch details below.
astral-tokio-tar insufficiently validates PAX extensions during extraction
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-32766.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
astral-tokio-tarReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
Impact
In versions 0.5.6 and earlier of astral-tokio-tar, malformed PAX extensions were silently skipped when parsing tar archives. This silent skipping (rather than rejection) of invalid PAX extensions could be used as a building block for a parser differential, for example by having astral-tokio-tar silently skip a malformed GNU “long link” extension so that a subsequent parser would misinterpret the extension.
In practice, exploiting this behavior in astral-tokio-tar requires a secondary misbehaving tar parser, i.e. one that insufficiently validates malformed PAX extensions and interprets them rather than skipping or erroring on them. Consequently this advisory is considered low-severity within astral-tokio-tar itself, as it requires a separate vulnerability against any unrelated tar parser.
Patches
Versions 0.6.0 and newer of astral-tokio-tar reject invalid PAX extensions, rather than silently skipping them.
Workarounds
Users are advised to upgrade to version 0.6.0 or newer to address this advisory.
Most users should experience no breaking changes as a result of the patch above. Some users who attempt to extract poorly constructed tar files may experience errors; users should re-construct their tar files with a conforming tar parser.
Attribution
- Sergei Zimmerman (@xokdvium)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | astral-tokio-tar | all versions | 0.6.0cargo update -p astral-tokio-tar --precise 0.6.0 |
Affected Products
astral-tokio-tarastralDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for astral-tokio-tar, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update astral-tokio-tar to 0.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-32766 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This is a LOW impact flaw in `astral-tokio-tar` where malformed PAX extensions are silently ignored, potentially leading to a parser differential. Exploitation requires a secondary, vulnerable tar program that misinterprets these extensions. Red Hat products are only affected if they integrate `astral-tokio-tar` with…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2026-32766 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2026-32766 in your dependencies?
Find it across crates.io, including transitive dependencies.