NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2026-32613 — echo-pipelinetriggers

CRITICAL

CVE-2026-32613 is a critical-severity (CVSS 9.9) Code Injection vulnerability in io.spinnaker.echo:echo-pipelinetriggers. A fix is available for io.spinnaker.echo:echo-pipelinetriggers — see the affected versions and patch details below.

Spinnaker vulnerable to RCE via expression parsing due to unrestricted context handling

Also known asGHSA-69rw-45wj-g4v6
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-32613.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk-0.11%
Lower risk than most CVEs46th percentile — riskier than 46% of all scored CVEsHighest risk
0.00%0.39%0.78%1.16%0.1%0.6%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕io.spinnaker.echo:echo-pipelinetriggers☕io.spinnaker.echo:echo-pipelinetriggers☕io.spinnaker.echo:echo-pipelinetriggers

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Spinnaker is an open source, multi-cloud continuous delivery platform. Echo like some other services, uses SPeL (Spring Expression Language) to process information - specifically around expected artifacts. In versions prior to 2026.1.0, 2026.0.1, 2025.4.2, and 2025.3.2, unlike orca, it was NOT restricting that context to a set of trusted classes, but allowing FULL JVM access. This enabled a user to use arbitrary java classes which allow deep access to the system. This enabled the ability to invoke commands, access files, etc. Versions 2026.1.0, 2026.0.1, 2025.4.2, and 2025.3.2 contain a patch. As a workaround, disable echo entirely.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenio.spinnaker.echo:echo-pipelinetriggers≥ 2026.0-0&&< 2026.0.12026.0.1io.spinnaker.echo:echo-pipelinetriggers:2026.0.1
☕Mavenio.spinnaker.echo:echo-pipelinetriggers≥ 2025.4-0&&< 2025.4.22025.4.2io.spinnaker.echo:echo-pipelinetriggers:2025.4.2
☕Mavenio.spinnaker.echo:echo-pipelinetriggersall versions2025.3.2io.spinnaker.echo:echo-pipelinetriggers:2025.3.2

Affected Products

1 product · 3 configurations
Application
spinnakerlinuxfoundation
≥ 2026.0.0 && < 2026.0.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.spinnaker.echo:echo-pipelinetriggers, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update io.spinnaker.echo:echo-pipelinetriggers to 2026.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-32613 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Spinnaker is an open source, multi-cloud continuous delivery platform. Echo like some other services, uses SPeL (Spring Expression Language) to process information - specifically around expected artifacts. In versions prior to 2026.1.0, 2026.0.1, 2025.4.2, and 2025.3.2, unlike orca, it was NOT restricting that context to a set of trusted classes, but allowing FULL JVM access. This enabled a user to use arbitrary java classes which allow deep access to the system. This enabled the ability to invoke commands, access files, etc. Versions 2026.1.0, 2026.0.1, 2025.4.2, and 2025.3.2 contain a patch.
O3 Security · Impact-Aware SCA

Is CVE-2026-32613 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-32613: echo-pipelinetriggers — Fixed in 2026.0.1