NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2026-32057 — openclaw

Fix: openclaw/openclaw@ec45c31

CVE-2026-32057 is a CWE-807 vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.

OpenClaw < 2026.2.25 - Authentication Bypass via Control UI client.id Parameter

Also known asGHSA-vvgp-4c28-m3jm
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-32057.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs29th percentile — riskier than 29% of all scored CVEsHighest risk
0.00%0.37%0.74%1.11%0.1%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

133other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
openclawnpm
2.5Mdownloads / week

Description

Summary

A trusted-proxy Control UI pairing bypass accepted client.id=control-ui without device identity checks. The bypass did not require operator role, so an authenticated node role session could connect unpaired and reach node event methods.

Impact

With trusted-proxy authentication enabled, a node role websocket client could skip pairing by using client.id=control-ui. That created an authorization boundary bypass from a node-scoped connection into node event execution flows.

Affected Packages / Versions

  • Package: openclaw (npm)
  • Affected range: <= 2026.2.24
  • Latest published vulnerable version: 2026.2.24
  • Patched in next release: 2026.2.25 (pre-set below so this advisory is ready to publish after npm release)

Fix

The trusted-proxy Control UI bypass now additionally requires role === "operator".

Fix Commit(s)

  • ec45c317f5d0631a3d333b236da58c4749ede2a3

Release Process Note

patched_versions is intentionally pre-set to the release (2026.2.25). Advisory published with npm release 2026.2.25.2.25` is published, the remaining GHSA action is to publish this advisory.

OpenClaw thanks @tdjackey for reporting.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmopenclawall versions2026.2.25npm install openclaw@2026.2.25

Affected Products

1 product · 1 configurations
Application
openclawopenclaw
< 2026.2.25
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update openclaw to 2026.2.25 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-32057 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

## Summary A trusted-proxy Control UI pairing bypass accepted `client.id=control-ui` without device identity checks. The bypass did not require `operator` role, so an authenticated `node` role session could connect unpaired and reach node event methods. ## Impact With trusted-proxy authentication enabled, a `node` role websocket client could skip pairing by using `client.id=control-ui`. That created an authorization boundary bypass from a node-scoped connection into node event execution flows. ## Affected Packages / Versions - Package: `openclaw` (npm) - Affected range: `<= 2026.2.24` - Late
O3 Security · Impact-Aware SCA

Is CVE-2026-32057 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-32057: openclaw — Fixed in 2026.2.25