NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2026-3112 — server

MEDIUM

CVE-2026-3112 is a medium-severity (CVSS 6.8) Path Traversal vulnerability in github.com/mattermost/mattermost/server/v8. A fix is available for github.com/mattermost/mattermost/server/v8 — see the affected versions and patch details below.

Arbitrary File Read via Advanced Logging Support Packet

Also known asGHSA-3mw5-466q-295qGO-2026-5092
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-3112.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs38th percentile — riskier than 38% of all scored CVEsHighest risk
0.00%0.32%0.65%0.97%0.0%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Mattermost versions 11.4.x <= 11.4.0, 11.3.x <= 11.3.1, 11.2.x <= 11.2.3, 10.11.x <= 10.11.11 fail to validate Advanced Logging file target paths which allows system administrators to read arbitrary host files via malicious AdvancedLoggingJSON configuration in support packet generation. Mattermost Advisory ID: MMSA-2025-00562

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 11.4.0-rc1&&< 11.4.111.4.1go get github.com/mattermost/mattermost/server/v8@v11.4.1
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 11.3.0-rc1&&< 11.3.211.3.2go get github.com/mattermost/mattermost/server/v8@v11.3.2
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 11.2.0-rc1&&< 11.2.411.2.4go get github.com/mattermost/mattermost/server/v8@v11.2.4
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 10.11.0-rc1&&< 10.11.1210.11.12go get github.com/mattermost/mattermost/server/v8@v10.11.12
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 8.0.0-20260105080200-d27a2195068d&&< 8.0.0-20260217110922-b7d4a1f1f59b8.0.0-20260217110922-b7d4a1f1f59bgo get github.com/mattermost/mattermost/server/v8@v8.0.0-20260217110922-b7d4a1f1f59b

Affected Products

1 product · 4 configurations
Application
mattermost servermattermost
≥ 11.3.0 && < 11.3.2
1 version
11.4.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost/server/v8, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost/server/v8 to 11.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-3112 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Mattermost versions 11.4.x <= 11.4.0, 11.3.x <= 11.3.1, 11.2.x <= 11.2.3, 10.11.x <= 10.11.11 fail to validate Advanced Logging file target paths which allows system administrators to read arbitrary host files via malicious AdvancedLoggingJSON configuration in support packet generation. Mattermost Advisory ID: MMSA-2025-00562
O3 Security · Impact-Aware SCA

Is CVE-2026-3112 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2026-3112: server — Fixed in 11.4.1