NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2026-28683 — gokapi

HIGH

CVE-2026-28683 is a high-severity (CVSS 8.7) Cross-site Scripting (XSS) vulnerability in github.com/forceu/gokapi. A fix is available for github.com/forceu/gokapi — see the affected versions and patch details below.

Gokapi: Stored XSS in SVG Hotlinks

Also known asGHSA-3c22-5j5m-4jq7GO-2026-4612
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-28683.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk-0.03%
Lower risk than most CVEs11th percentile — riskier than 11% of all scored CVEsHighest risk
0.00%0.25%0.49%0.74%0.0%0.2%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/forceu/gokapi

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Summary

If a malicious authenticated user uploads SVG and creates a hotlink for it, they achieve stored XSS.

Details

The hotlinking functionality fails to properly handle scripts included in the SVGs, allowing authenticated attackers with the ability to upload and hotlink file to execute arbitrary JS.

Issue found by aisafe.io

Impact

Authenticated attackers with the ability to upload and hotlink files can execute arbitrary JavaScript.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/forceu/gokapiall versions2.2.3go get github.com/forceu/gokapi@v2.2.3

Affected Products

1 product · 1 configurations
Application
gokapiforceu
< 2.2.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/forceu/gokapi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/forceu/gokapi to 2.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-28683 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Summary If a malicious authenticated user uploads SVG and creates a hotlink for it, they achieve stored XSS. ### Details The hotlinking functionality fails to properly handle scripts included in the SVGs, allowing authenticated attackers with the ability to upload and hotlink file to execute arbitrary JS. *Issue found by [aisafe.io](https://aisafe.io/)* ### Impact Authenticated attackers with the ability to upload and hotlink files can execute arbitrary JavaScript.
O3 Security · Impact-Aware SCA

Is CVE-2026-28683 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2026-28683: gokapi XSS — Fixed in 2.2.3