NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2026-28486 — openclaw

Fix: openclaw/openclaw@3aa94af

CVE-2026-28486 is a Path Traversal vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.

OpenClaw 2026.1.16-2 < 2026.2.14 - Path Traversal (Zip Slip) in Archive Extraction via Installation Commands

Also known asGHSA-v892-hwpg-jwqp
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-28486.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs7th percentile — riskier than 7% of all scored CVEsHighest risk
0.00%0.23%0.46%0.70%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

132other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
openclawnpm
2.4Mdownloads / week

Description

Summary

A path traversal (Zip Slip) issue in archive extraction during explicit installation commands could allow a crafted archive to write files outside the intended extraction directory.

Affected Packages / Versions

  • Package: openclaw (npm)
  • Affected versions: >=2026.1.16-2 <2026.2.14
  • Fixed version: 2026.2.14

Affected Commands / Flows

This only affects users who run installation commands against an untrusted archive (local file or download URL), for example:

  • openclaw skills install (download+extract installers)
  • openclaw hooks install (archive installs)
  • openclaw plugins install (archive installs)
  • openclaw signal install (signal-cli asset extraction)

It is not triggered by receiving messages or normal gateway operation.

Impact

Arbitrary file write as the current user. In the worst case this can be used for persistence or code execution if an attacker can convince a user to install a crafted archive.

Fix

  • Fix commit: 3aa94afcfd12104c683c9cad81faf434d0dadf87
  • Released in: 2026.2.14

Credits

OpenClaw thanks @markmusson for reporting.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmopenclaw≥ 2026.1.16-2&&< 2026.2.142026.2.14npm install openclaw@2026.2.14

Affected Products

1 product · 2 configurations
Application
openclawopenclaw
≥ 2026.1.20 && < 2026.2.14
1 version
2026.1.16-2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update openclaw to 2026.2.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-28486 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

## Summary A path traversal (Zip Slip) issue in archive extraction during explicit installation commands could allow a crafted archive to write files outside the intended extraction directory. ## Affected Packages / Versions - Package: `openclaw` (npm) - Affected versions: `>=2026.1.16-2 <2026.2.14` - Fixed version: `2026.2.14` ## Affected Commands / Flows This only affects users who run installation commands against an untrusted archive (local file or download URL), for example: - `openclaw skills install` (download+extract installers) - `openclaw hooks install` (archive installs) - `op
O3 Security · Impact-Aware SCA

Is CVE-2026-28486 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-28486: openclaw — Fixed in 2026.2.14