CVE-2026-28474 — @openclaw/nextcloud-talk
Fix: openclaw/openclaw@6b4b604CVE-2026-28474 is a CWE-863 vulnerability in @openclaw/nextcloud-talk. A fix is available for @openclaw/nextcloud-talk — see the affected versions and patch details below.
OpenClaw Nextcloud Talk < 2026.2.6 - Allowlist Bypass via actor.name Display Name Spoofing
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-28474.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@openclaw/nextcloud-talknpmDescription
Summary
In affected versions of the optional Nextcloud Talk plugin (installed separately; not bundled with the core OpenClaw install), an untrusted webhook field (actor.name, display name) could be treated as an allowlist identifier. An attacker could change their Nextcloud display name to match an allowlisted user ID and bypass DM or room allowlists.
Details
Nextcloud Talk webhook payloads provide a stable sender identifier (actor.id) and a mutable display name (actor.name). In affected versions, the plugin’s allowlist matching accepted equality on the display name, which is attacker-controlled.
Affected Packages / Versions
- Package:
@openclaw/nextcloud-talk(npm) - Affected:
<= 2026.2.2 - Fixed:
>= 2026.2.6
Note: This advisory applies to the optional Nextcloud Talk plugin package. Core openclaw is not impacted unless you installed and use @openclaw/nextcloud-talk.
Fix Commit(s)
Timeline
- Introduced: 660f87278c9f292061e097441e0b10c20d62b31b (2026-01-20)
- Fixed in repo: 6b4b6049b47c3329a7014509594647826669892d (2026-02-04 UTC)
- First fixed tag containing the change: v2026.2.3
- First fixed npm release of
@openclaw/nextcloud-talk:2026.2.6(published 2026-02-07 UTC)
Mitigation
Upgrade @openclaw/nextcloud-talk to >= 2026.2.6.
Release Process Note
The patched version range is set to the first npm release that contains the fix. Once you are ready, you can publish this advisory without additional version edits.
Thanks @MegaManSec (https://joshua.hu) of AISLE Research Team for reporting.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @openclaw/nextcloud-talk | all versions | 2026.2.6npm install @openclaw/nextcloud-talk@2026.2.6 |
Affected Products
openclawopenclawDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @openclaw/nextcloud-talk, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @openclaw/nextcloud-talk to 2026.2.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-28474 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2026-28474 in your dependencies?
Find it across npm, including transitive dependencies.