CVE-2026-28222 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in wagtail. A fix is available for wagtail — see the affected versions and patch details below.
Wagtail: Improper escaping of HTML (Cross-site Scripting) on TableBlock class attributes
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-28222.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
wagtail🐍wagtail🐍wagtail🐍wagtailReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A stored Cross-site Scripting (XSS) vulnerability exists on rendering TableBlock blocks within a StreamField. A user with access to create or edit pages containing TableBlock StreamField blocks is able to set specially-crafted class attributes on the block which run arbitrary JavaScript code when the page is viewed. When viewed by a user with higher privileges, this could lead to performing actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin, and only affects sites using TableBlock.
Patches
Patched versions have been released as Wagtail 6.3.8, 7.0.6, 7.2.3 and 7.3.1.
Workarounds
Site owners who are unable to upgrade to the new versions can remediate the vulnerability by setting a template attribute on all TableBlock definitions, referencing a template that does not output class attributes. For example:
<!-- For use with TableBlock(template="path/to/table_block.html") -->
<table>
{% if table_caption %}
<caption>{{ table_caption }}</caption>
{% endif %}
{% if table_header %}
<thead>
<tr>
{% for cell in table_header %}
<th scope="col">{{ cell }}</th>
{% endfor %}
</tr>
</thead>
{% endif %}
<tbody>
{% for row in data %}
<tr>
{% for cell in row %}
{% if first_col_is_header and forloop.first %}
<th scope="row">{{ cell }}</th>
{% else %}
<td>{{ cell }}</td>
{% endif %}
{% endfor %}
</tr>
{% endfor %}
</tbody>
</table>
Acknowledgements
Many thanks to Guan Chenxian (@GCXWLP) for reporting this issue.
For more information
If there are any questions or comments about this advisory:
- Visit Wagtail's support channels
- Email Wagtail at [email protected] (view the security policy for more information).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | wagtail | all versions | 6.3.8pip install --upgrade 'wagtail==6.3.8' |
| 🐍PyPI | wagtail | ≥ 6.4rc1&&< 7.0.6 | 7.0.6pip install --upgrade 'wagtail==7.0.6' |
| 🐍PyPI | wagtail | ≥ 7.1rc1&&< 7.2.3 | 7.2.3pip install --upgrade 'wagtail==7.2.3' |
| 🐍PyPI | wagtail | ≥ 7.3rc1&&< 7.3.1 | 7.3.1pip install --upgrade 'wagtail==7.3.1' |
Affected Products
wagtailtorchboxDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wagtail, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update wagtail to 6.3.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-28222 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2026-28222 in your dependencies?
Find it across PyPI, including transitive dependencies.