NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2026-27971 — qwik

CVE-2026-27971 is a Deserialization of Untrusted Data vulnerability in @builder.io/qwik. A fix is available for @builder.io/qwik — see the affected versions and patch details below.

Qwik affected by unauthenticated RCE via server$ Deserialization

Also known asGHSA-p9x5-jp3h-96mm
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-27971.

EPSS Exploitation Probability

via FIRST.org ↗
5.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
0.00%11.1%22.1%33.2%24.4%5.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

29other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@builder.io/qwiknpm
53Kdownloads / week

Description

Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@builder.io/qwikall versions1.19.1npm install @builder.io/qwik@1.19.1

Affected Products

1 product · 1 configurations
Application
qwikqwik
< 1.19.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @builder.io/qwik, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @builder.io/qwik to 1.19.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-27971 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

How to detect CVE-2026-27971

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2026-27971 -u https://target
Template
Qwik - Unauthenticated RCE via server$ Deserialization
Severity
critical
Impact
Unauthenticated attackers can execute arbitrary code on the server, leading to full system compromise.
Remediation
Update to version 1.19.1 or later.

Template by ProjectDiscovery nuclei-templates (omarkurt), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.
O3 Security · Impact-Aware SCA

Is CVE-2026-27971 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-27971: qwik RCE — Fixed in 1.19.1