NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2026-27656 — mattermost-server

MEDIUM

CVE-2026-27656 is a medium-severity (CVSS 5.7) CWE-303 vulnerability in github.com/mattermost/mattermost-server. A fix is available for github.com/mattermost/mattermost-server — see the affected versions and patch details below.

Account Takeover via Substring Matching in OpenID Connect Authentication

Also known asGHSA-fg35-5rf6-qg3gGO-2026-5360
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-27656.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs8th percentile — riskier than 8% of all scored CVEsHighest risk
0.00%0.27%0.54%0.81%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost/server/v8

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Mattermost versions 11.4.x <= 11.4.0, 11.3.x <= 11.3.1, 11.2.x <= 11.2.3, 10.11.x <= 10.11.11 fail to properly validate user identity in the OpenID {{IsSameUser()}} comparison logic, which allows an attacker to take over arbitrary user accounts via an overly permissive substring matching flaw in the user discovery flow.. Mattermost Advisory ID: MMSA-2026-00590

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost-server≥ 11.4.0-rc1&&< 11.4.111.4.1go get github.com/mattermost/mattermost-server@v11.4.1
🐹Gogithub.com/mattermost/mattermost-server≥ 11.3.0-rc1&&< 11.3.211.3.2go get github.com/mattermost/mattermost-server@v11.3.2
🐹Gogithub.com/mattermost/mattermost-server≥ 11.2.0-rc1&&< 11.2.411.2.4go get github.com/mattermost/mattermost-server@v11.2.4
🐹Gogithub.com/mattermost/mattermost-server≥ 10.11.0-rc1&&< 10.11.1210.11.12go get github.com/mattermost/mattermost-server@v10.11.12
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 8.0.0-20260105080200-d27a2195068d&&< 8.0.0-20260217110922-b7d4a1f1f59b8.0.0-20260217110922-b7d4a1f1f59bgo get github.com/mattermost/mattermost/server/v8@v8.0.0-20260217110922-b7d4a1f1f59b

Affected Products

1 product · 4 configurations
Application
mattermost servermattermost
≥ 11.4.0 && < 11.4.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost-server to 11.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-27656 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Mattermost versions 11.4.x <= 11.4.0, 11.3.x <= 11.3.1, 11.2.x <= 11.2.3, 10.11.x <= 10.11.11 fail to properly validate user identity in the OpenID {{IsSameUser()}} comparison logic, which allows an attacker to take over arbitrary user accounts via an overly permissive substring matching flaw in the user discovery flow.. Mattermost Advisory ID: MMSA-2026-00590
O3 Security · Impact-Aware SCA

Is CVE-2026-27656 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2026-27656: mattermost-server — Fixed in 11.4.1