NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2026-27206 — json-serializer

HIGHFix: zumba/json-serializer@bf26227

CVE-2026-27206 is a high-severity (CVSS 8.1) Deserialization of Untrusted Data vulnerability in zumba/json-serializer. A fix is available for zumba/json-serializer — see the affected versions and patch details below.

Zumba Json Serializer has a potential PHP Object Injection via Unrestricted @type in unserialize()

Also known asGHSA-v7m3-fpcr-h7m2
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-27206.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.51%1.01%1.52%0.1%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘zumba/json-serializer

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Description

The zumba/json-serializer library allows deserialization of PHP objects from JSON using a special @type field.

Prior to version 3.2.3, the deserializer would instantiate any class specified in the @type field without restriction. When processing untrusted JSON input, this behavior may allow an attacker to instantiate arbitrary classes available in the application.

If a vulnerable application passes attacker-controlled JSON into JsonSerializer::unserialize() and contains classes with dangerous magic methods (such as __wakeup() or __destruct()), this may lead to PHP Object Injection and potentially Remote Code Execution (RCE), depending on available gadget chains in the application or its dependencies.

This behavior is similar in risk profile to PHP's native unserialize() when used without the allowed_classes restriction.

Impact

This vulnerability allows instantiation of arbitrary PHP classes via the @type field when deserializing JSON.

Applications are impacted only if:

  • Untrusted or attacker-controlled JSON is passed into JsonSerializer::unserialize(), and
  • The application or its dependencies contain classes that can be leveraged as a gadget chain.

Successful exploitation may lead to:

  • Arbitrary code execution
  • Data exfiltration
  • File manipulation
  • Denial of service

Applications that only deserialize trusted data are not affected.

Patches

This issue is mitigated in version 3.2.3.

Version 3.2.3 introduces the method: setAllowedClasses(?array $allowedClasses)

This allows applications to restrict which classes may be instantiated during deserialization, similar to PHP's native unserialize() allowed_classes option.

Users should upgrade to version 3.2.3 or later and configure an appropriate class allowlist.

Workarounds

If upgrading is not immediately possible, applications should ensure that:

  • JsonSerializer::unserialize() is never called on untrusted or attacker-controlled JSON.
  • JSON input is validated and sanitized before deserialization.
  • Object instantiation via @type is disabled in application logic where possible.

After upgrading, users can mitigate risk by explicitly configuring:

$serializer->setAllowedClasses([]);

to disable all object instantiation, or by providing a strict allowlist of safe classes.

References

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistzumba/json-serializerall versions3.2.3composer require zumba/json-serializer:^3.2.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zumba/json-serializer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update zumba/json-serializer to 3.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-27206 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

### Description The `zumba/json-serializer` library allows deserialization of PHP objects from JSON using a special `@type` field. Prior to version 3.2.3, the deserializer would instantiate any class specified in the `@type` field without restriction. When processing untrusted JSON input, this behavior may allow an attacker to instantiate arbitrary classes available in the application. If a vulnerable application passes attacker-controlled JSON into JsonSerializer::unserialize() and contains classes with dangerous magic methods (such as `__wakeup()` or `__destruct()`), this may lead to PHP
O3 Security · Impact-Aware SCA

Is CVE-2026-27206 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2026-27206: json-serializer RCE — Fixed in 3.2.3