CVE-2026-26325 is a high-severity (CVSS 7.2) CWE-284 vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
OpenClaw Node host system.run rawCommand/command mismatch can bypass allowlist/approvals
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-26325.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmDescription
Summary
A mismatch between rawCommand and command[] in the node host system.run handler could cause allowlist/approval evaluation to be performed on one command while executing a different argv.
Affected Configurations
This only impacts deployments that:
- Use the node host / companion node execution path (
system.runon a node). - Enable allowlist-based exec policy (
security=allowlist) with approval prompting driven by allowlist misses (for exampleask=on-miss). - Allow an attacker to invoke
system.run.
Default/non-node configurations are not affected.
Impact
In affected configurations, an attacker who can invoke system.run can bypass allowlist enforcement and approval prompts by supplying an allowlisted rawCommand while providing a different command[] argv for execution.
Affected Packages / Versions
- Package:
openclaw(npm) - Affected versions:
<= 2026.2.13 - Patched version:
>= 2026.2.14(planned next release)
Fix
Enforce rawCommand/command[] consistency (gateway fail-fast + node host validation).
Fix Commit(s)
- cb3290fca32593956638f161d9776266b90ab891
Release Process Note
This advisory pre-sets the patched version to the planned next release (2026.2.14). Once [email protected] is published to npm, the advisory can be published without further edits.
Thanks @christos-eth for reporting.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | all versions | 2026.2.14npm install openclaw@2026.2.14 |
Affected Products
openclawopenclawDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.2.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-26325 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2026-26325 in your dependencies?
Find it across npm, including transitive dependencies.