NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2026-26188 — craft-freeform

Fix: solspace/craft-freeform@b9adad6

CVE-2026-26188 is a Cross-site Scripting (XSS) vulnerability in solspace/craft-freeform. A fix is available for solspace/craft-freeform — see the affected versions and patch details below.

Solspace Freeform plugin affected by Stored Cross-Site Scripting (XSS) in Freeform Craft Plugin CP UI (builder/integrations)

Also known asGHSA-jp3q-wwp3-pwv9
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-26188.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs23th percentile — riskier than 23% of all scored CVEsHighest risk
0.00%0.27%0.54%0.82%0.0%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘solspace/craft-freeform

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Summary An authenticated, low-privilege user (able to create/edit forms) can inject arbitrary HTML/JS into the Craft Control Panel (CP) builder and integrations views. User-controlled form labels and integration metadata are rendered with dangerouslySetInnerHTML without sanitization, leading to stored XSS that executes when any admin views the builder/integration screens.

Affected Product

  • Ecosystem: Packagist (Craft CMS plugin)
  • Package: solspace/craft-freeform
  • Version: <= 5.14.6 (latest observed). Likely all 5.x until patched.

Details

  • Root cause: Multiple user-controlled strings (field labels, section labels, integration icons, short names, WYSIWYG previews) are injected into React components using dangerouslySetInnerHTML without sanitization.
  • Evidence: dangerouslySetInnerHTML on user-controlled properties in bundled CP JS at packages/plugin/src/Resources/js/client/client.js.

PoCs

  • Label-based XSS:
    1. In Craft CP, create/edit a Freeform field and set its label to <img src=x onerror="alert('xss-label')">.
    2. Open the form builder view containing the field.
    3. Alert executes (stored XSS).
  • Integration icon SVG:
    1. Set an integration "icon SVG" to <svg><script>alert('xss-icon')</script></svg>.
    2. Open the integrations CP view.
    3. Script executes.

Impact Arbitrary JS in admin CP; session/CSRF token theft; potential full admin takeover via DOM-driven actions.

Remediation

  • Sanitize/HTML-encode all user-controlled strings before passing to dangerouslySetInnerHTML, or avoid it for labels/titles/icons.
  • Server-side: strip/escape disallowed tags on save for fields, integration metadata, WYSIWYG content.
  • Add regression tests with <img onerror> payloads to ensure no execution in builder/integration views.

Workarounds

  • Restrict form-edit permissions to trusted admins only until patched.
  • Consider CSP that disallows inline scripts (defense-in-depth only).

Credits

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsolspace/craft-freeform≥ 5.0.0&&< 5.14.75.14.7composer require solspace/craft-freeform:^5.14.7

Affected Products

1 product · 1 configurations
Application
freeformsolspace
≥ 5.0.0 && < 5.14.7
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for solspace/craft-freeform, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update solspace/craft-freeform to 5.14.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-26188 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

**Summary** An authenticated, low-privilege user (able to create/edit forms) can inject arbitrary HTML/JS into the Craft Control Panel (CP) builder and integrations views. User-controlled form labels and integration metadata are rendered with `dangerouslySetInnerHTML` without sanitization, leading to stored XSS that executes when any admin views the builder/integration screens. **Affected Product** - Ecosystem: Packagist (Craft CMS plugin) - Package: solspace/craft-freeform - Version: <= 5.14.6 (latest observed). Likely all 5.x until patched. **Details** - Root cause: Multiple user-controlle
O3 Security · Impact-Aware SCA

Is CVE-2026-26188 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2026-26188: craft-freeform XSS — Fixed in 5.14.7