CVE-2026-25990 — pillow
Fix: python-pillow/Pillow@9000313CVE-2026-25990 is a Out-of-bounds Write vulnerability in pillow. A fix is available for pillow — see the affected versions and patch details below.
Pillow has an out-of-bounds write when loading PSD images
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-25990.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
pillowReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
An out-of-bounds write may be triggered when loading a specially crafted PSD image. Pillow >= 10.3.0 users are affected.
Patches
Pillow 12.1.1 will be released shortly with a fix for this.
Workarounds
Image.open() has a formats parameter that can be used to prevent PSD images from being opened.
References
Pillow 12.1.1 will add release notes at https://pillow.readthedocs.io/en/stable/releasenotes/index.html
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | pillow | ≥ 10.3.0&&< 12.1.1 | 12.1.1pip install --upgrade 'pillow==12.1.1' |
Affected Products
pillowpythonDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pillow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pillow to 12.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-25990 is resolved across your whole dependency graph.
Workarounds
Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2026-25990 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ansible Automation Platform 2.5 for RHEL 8 | python3.12-pillow-0:12.1.1-1.el8ap | RHSA-2026:6278 |
| Red Hat Ansible Automation Platform 2.6 for RHEL 9 | python3.12-pillow-0:12.1.1-1.el9ap | RHSA-2026:6277 |
| Red Hat Satellite 6.16 for RHEL 8 | python-pillow-0:12.1.1-1.el8pc | RHSA-2026:14874 |
| Red Hat Satellite 6.17 for RHEL 9 | python-pillow-0:12.1.1-1.el9pc | RHSA-2026:14873 |
| Red Hat Satellite 6.18 for RHEL 9 | python3.12-pillow-0:12.1.1-1.el9pc | RHSA-2026:28385 |
| Red Hat AI Inference Server 3.2 | rhaiis/vllm-cuda-rhel9:1772160593 | RHSA-2026:3461 |
| Red Hat AI Inference Server 3.2 | rhaiis/vllm-rocm-rhel9:1772160625 | RHSA-2026:3462 |
| Red Hat AI Inference Server 3.2 | rhaiis/model-opt-cuda-rhel9:1772713830 | RHSA-2026:4128 |
Frequently Asked Questions
Is CVE-2026-25990 in your dependencies?
Find it across PyPI, including transitive dependencies.