CVE-2026-25804 — antrea
Fix: antrea-io/antrea@86c4b60CVE-2026-25804 is a Improper Authentication vulnerability in antrea.io/antrea. A fix is available for antrea.io/antrea — see the affected versions and patch details below.
Antrea has invalid enforcement order for network policy rules caused by integer overflow
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-25804.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
antrea.io/antrea🐹antrea.io/antreaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Antrea's network policy priority assignment system has a uint16 arithmetic overflow bug that causes incorrect OpenFlow priority calculations when handling a large numbers of policies with various priority values. This results in potentially incorrect traffic enforcement.
If a user creates a large number of Antrea NetworkPolicies (ANP or ACNP) with varying priorities, some rules with lower logical priorities (higher numerical priority values) may take precedence over rules with higher logical priorities (lower numerical priority values). Traffic that should be denied by the configured Antrea NetworkPolicies may end up being allowed, potentially letting an attacker access a sensitive service. Traffic that should be allowed by the configured Antrea NetworkPolicies may end up being denied, breaking applications and potentially opening the door for denial-of-service attacks.
The Antrea NetworkPolicy system comes with support for priority Tiers. Rules defined within a Tier cannot take precedence over rules defined in higher priority Tiers. Some users / roles may only be authorized to define within specific Tiers. This security vulnerability enables such users to intentionally "escape" their Tier and override rules in higher priority Tiers.
Antrea deployments that only use upstream Kubernetes NetworkPolicies - and do not use Antrea NetworkPolicies - are not affected.
Patches
https://github.com/antrea-io/antrea/pull/7496 Antrea v2.5.0 Antrea v2.4.3 Antrea v2.3.2
Workarounds
Antrea deployments that only use upstream Kubernetes NetworkPolicies - and do not use Antrea NetworkPolicies - are not affected.
For users leveraging Antrea NetworkPolicies, there is no way to fix or remediate the vulnerability without upgrading.
Resources
https://gist.github.com/antoninbas/c429cc3e5bb8479ba7ff38fd6fde59d9 https://github.com/antrea-io/antrea/pull/7496 https://github.com/antrea-io/antrea/blob/main/docs/antrea-network-policy.md
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | antrea.io/antrea | all versions | 2.3.2go get antrea.io/antrea@v2.3.2 |
| 🐹Go | antrea.io/antrea | ≥ 2.4.0&&< 2.4.3 | 2.4.3go get antrea.io/antrea@v2.4.3 |
Affected Products
antrealinuxfoundationDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for antrea.io/antrea, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update antrea.io/antrea to 2.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-25804 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is CVE-2026-25804 in your dependencies?
Find it across Go, including transitive dependencies.