NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2026-25544 — @payloadcms/drizzle

CRITICAL

CVE-2026-25544 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in @payloadcms/drizzle. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for @payloadcms/drizzle — see the affected versions and patch details below.

Payload has an SQL Injection in JSON/RichText Queries on PostgreSQL/SQLite Adapters

Also known asGHSA-xx6w-jxg9-2wh8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-25544.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk-0.04%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.46%0.92%1.38%0.0%0.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

13other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@payloadcms/drizzlenpm
977Kdownloads / week

Description

Impact

When querying JSON or richText fields, user input was directly embedded into SQL without escaping, enabling blind SQL Injection attacks. An unauthenticated attacker could extract sensitive data (emails, password reset tokens) and achieve full account takeover without password cracking.

Users are affected if ALL of these are true:

  1. Payload version < v3.73.0
  2. Using a Drizzle-based database adapter (@payloadcms/drizzle as dependency):
    • @payloadcms/db-postgres
    • @payloadcms/db-vercel-postgres
    • @payloadcms/db-sqlite
    • @payloadcms/db-d1-sqlite
  3. At least one accessible collection that has a type: 'json' or type: 'richText' field where access.read returns anything other than false (true or Where constraint)

Users are NOT affected if:

  • Using @payloadcms/db-mongodb
  • No JSON or richText fields exist in any collection
  • All JSON/richText fields have access: { read: () => false }

Patches

Upgrade to Payload v3.73.0 or later.

Workarounds

If a project cannot upgrade immediately, add access: { read: () => false } to all JSON and richText fields as a temporary mitigation.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@payloadcms/drizzleall versions3.73.0npm install @payloadcms/drizzle@3.73.0

Affected Products

1 product · 1 configurations
Application
payloadpayloadcms
< 3.73.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-52671webappsmultiple

Payload CMS 3.72.0 - Blind SQL Injection

by cardosource · Sep 1, 2026

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @payloadcms/drizzle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @payloadcms/drizzle to 3.73.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-25544 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

### Impact When querying JSON or richText fields, user input was directly embedded into SQL without escaping, enabling blind SQL Injection attacks. An unauthenticated attacker could extract sensitive data (emails, password reset tokens) and achieve full account takeover without password cracking. **Users are affected if ALL of these are true:** 1. Payload version < v3.73.0 2. Using a Drizzle-based database adapter (`@payloadcms/drizzle` as dependency): - `@payloadcms/db-postgres` - `@payloadcms/db-vercel-postgres` - `@payloadcms/db-sqlite` - `@payloadcms/db-d1-sqlite` 3. At leas
O3 Security · Impact-Aware SCA

Is CVE-2026-25544 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-25544: @payloadcms/drizzle — Fixed in 3.73.0