CVE-2026-24748 — kargo
Fix: akuity/kargo@23646eaCVE-2026-24748 is a CWE-863 vulnerability in github.com/akuity/kargo. A fix is available for github.com/akuity/kargo — see the affected versions and patch details below.
Kargo's `GetConfig()` and `RefreshResource()` API endpoints allow unauthenticated access
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-24748.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
github.com/akuity/kargo🐹github.com/akuity/kargo🐹github.com/akuity/kargoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A bug was found with authentication checks on the GetConfig() API endpoint. This allowed unauthenticated users to access this endpoint by specifying an Authorization header with any non-empty Bearer token value, regardless of validity. This vulnerability did allow for exfiltration of configuration data such as endpoints for connected Argo CD clusters. This data could allow an attacker to enumerate cluster URLs and namespaces for use in subsequent attacks.
Additionally, the same bug affected the RefreshResource endpoint. This endpoint does not lead to any information disclosure, but could be used by an unauthenticated attacker to perform a denial-of-service style attack against the Kargo API. RefreshResource sets an annotation on specific Kubernetes resources to trigger reconciliations. If run on a constant loop, this could also slow down legitimate requests to the Kubernetes API server.
This vulnerability was identified by security researchers, and there are no known reports of exploitation in the wild.
Patches
This problem has been patched in the previous 3 versions of Kargo. Based on our information, almost all users are on one of these versions. If for some reason you cannot upgrade from an earlier version, please reach out to us.
Workarounds
There are no workarounds for this issue, so it is highly recommended to upgrade at the earliest possible
Additional details
This issue was caused by fallback logic in token authentication. The majority of Kargo endpoints are backed by Kubernetes objects, and for these endpoints, unrecognized token types are passed to the Kubernetes API for validation. However, the affected endpoints do not use Kubernetes or used an internal client not subject to authentication, so unrecognized tokens had no validation fallback. As a result, any request with a non-empty Bearer token in the Authorization header was incorrectly treated as authorized.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/akuity/kargo | all versions | 1.6.3go get github.com/akuity/kargo@v1.6.3 |
| 🐹Go | github.com/akuity/kargo | ≥ 1.7.0-rc.1&&< 1.7.7 | 1.7.7go get github.com/akuity/kargo@v1.7.7 |
| 🐹Go | github.com/akuity/kargo | ≥ 1.8.0-rc.1&&< 1.8.7 | 1.8.7go get github.com/akuity/kargo@v1.8.7 |
Affected Products
kargoakuityDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/akuity/kargo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/akuity/kargo to 1.6.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-24748 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2026-24748 in your dependencies?
Find it across Go, including transitive dependencies.