NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2026-24747 — pytorch

HIGH

CVE-2026-24747 is a high-severity (CVSS 8.8) Code Injection vulnerability in pytorch. A fix is available for pytorch — see the affected versions and patch details below.

PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files

Also known asBIT-pytorch-2026-24747GHSA-63cw-57p8-fm3pPYSEC-2026-1856PYSEC-2026-2286
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-24747.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.00%0.44%0.87%1.31%0.1%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍pytorch

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Summary

A vulnerability in PyTorch's weights_only unpickler allows an attacker to craft a malicious checkpoint file (.pth) that, when loaded with torch.load(..., weights_only=True), can corrupt memory and potentially lead to arbitrary code execution.

Vulnerability Details

The weights_only=True unpickler failed to properly validate pickle opcodes and storage metadata, allowing:

  1. Heap memory corruption via SETITEM/SETITEMS opcodes applied to non-dictionary types
  2. Storage size mismatch between declared element count and actual data in the archive

Impact

An attacker who can convince a user to load a malicious checkpoint file may achieve arbitrary code execution in the context of the victim's process.

Credit

Ji'an Zhou

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpytorchall versions2.10.0pip install --upgrade 'pytorch==2.10.0'

Affected Products

1 product · 1 configurations
Application
pytorchlinuxfoundation
< 2.10.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pytorch, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pytorch to 2.10.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-24747 is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat OpenShift AI 2.25rhoai/odh-vllm-gaudi-rhel9:1780069069RHSA-2026:24977

Frequently Asked Questions

### Summary A vulnerability in PyTorch's `weights_only` unpickler allows an attacker to craft a malicious checkpoint file (`.pth`) that, when loaded with `torch.load(..., weights_only=True)`, can corrupt memory and potentially lead to arbitrary code execution. ### Vulnerability Details The `weights_only=True` unpickler failed to properly validate pickle opcodes and storage metadata, allowing: 1. **Heap memory corruption** via `SETITEM`/`SETITEMS` opcodes applied to non-dictionary types 2. **Storage size mismatch** between declared element count and actual data in the archive ### Impact A
O3 Security · Impact-Aware SCA

Is CVE-2026-24747 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2026-24747: pytorch RCE — Fixed in 2.10.0