NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
LOW severity

CVE-2026-24656 — org.apache.karaf.decanter…

LOWFix: apache/karaf-decanter@9d7058d

CVE-2026-24656 is a low-severity (CVSS 3.7) Deserialization of Untrusted Data vulnerability in org.apache.karaf.decanter.collector:org.apache.karaf.decanter.collector.log.socket. A fix is available for org.apache.karaf.decanter.collector:org.apache.karaf.decanter.collector.log.socket — see the affected versions and patch details below.

Apache Karaf: Decanter log-socket collector has deserialization vulnerability

Also known asGHSA-jmw5-58c7-587h
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk-0.04%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.00%0.41%0.82%1.23%0.0%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.karaf.decanter.collector:org.apache.karaf.decanter.collector.log.socket

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Deserialization of Untrusted Data vulnerability in Apache Karaf Decanter.

The Decanter log socket collector exposes the port 4560, without authentication. If the collector exposes allowed classes property, this configuration can be bypassed. It means that the log socket collector is vulnerable to deserialization of untrusted data, eventually causing DoS.

NB: Decanter log socket collector is not installed by default. Users who have not installed Decanter log socket are not impacted by this issue.

This issue affects Apache Karaf Decanter before 2.12.0.

Users are recommended to upgrade to version 2.12.0, which fixes the issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.karaf.decanter.collector:org.apache.karaf.decanter.collector.log.socketall versions2.12.0org.apache.karaf.decanter.collector:org.apache.karaf.decanter.collector.log.socket:2.12.0

Affected Products

1 product · 1 configurations
Application
karaf decanterapache
< 2.12.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.karaf.decanter.collector:org.apache.karaf.decanter.collector.log.socket, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.karaf.decanter.collector:org.apache.karaf.decanter.collector.log.socket to 2.12.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-24656 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

Deserialization of Untrusted Data vulnerability in Apache Karaf Decanter. The Decanter log socket collector exposes the port 4560, without authentication. If the collector exposes allowed classes property, this configuration can be bypassed. It means that the log socket collector is vulnerable to deserialization of untrusted data, eventually causing DoS. NB: Decanter log socket collector is not installed by default. Users who have not installed Decanter log socket are not impacted by this issue. This issue affects Apache Karaf Decanter before 2.12.0. Users are recommended to upgrade to v
O3 Security · Impact-Aware SCA

Is CVE-2026-24656 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-24656: org.apache.karaf — Fixed in 2.12.0