NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2026-23906 — druid-basic-security

CRITICAL

CVE-2026-23906 is a critical-severity (CVSS 9.8) Improper Authentication vulnerability in org.apache.druid.extensions:druid-basic-security. A fix is available for org.apache.druid.extensions:druid-basic-security — see the affected versions and patch details below.

Apache Druid: Authentication Bypass via LDAP Anonymous Bind

Also known asGHSA-q672-hfc7-g833
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-23906.

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs67th percentile — riskier than 67% of all scored CVEsHighest risk
0.00%0.54%1.09%1.63%0.1%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.druid.extensions:druid-basic-security

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Affected Products and Versions

  • Apache Druid
  • Affected Versions: 0.17.0 through 35.x (all versions prior to 36.0.0)
  • Prerequisites: * druid-basic-security extension enabled
  • LDAP authenticator configured
  • Underlying LDAP server permits anonymous bind                                                                                                                                                   

Vulnerability Description

An authentication bypass vulnerability exists in Apache Druid when using the druid-basic-security extension with LDAP authentication. If the underlying LDAP server is configured to allow anonymous binds, an attacker can bypass authentication by providing an existing username with an empty password. This allows unauthorized access to otherwise restricted Druid resources without valid credentials.

The vulnerability stems from improper validation of LDAP authentication responses when anonymous binds are permitted, effectively treating anonymous bind success as valid user authentication.

Impact

A remote, unauthenticated attacker can:

  • Gain unauthorized access to the Apache Druid cluster
  • Access sensitive data stored in Druid datasources
  • Execute queries and potentially manipulate data
  • Access administrative interfaces if the bypassed account has elevated privileges
  • Completely compromise the confidentiality, integrity, and availability of the Druid deployment                                                                                                                                                                                    

Mitigation   Immediate Mitigation (No Druid Upgrade Required):                                                                                                                                                  

  • Disable anonymous bind on your LDAP server. This prevents the vulnerability from being exploitable and is the recommended immediate action.

Resolution

  • Upgrade Apache Druid to version 36.0.0 or later, which includes fixes to properly reject anonymous LDAP bind attempts.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.druid.extensions:druid-basic-security≥ 0.17.0&&< 36.0.036.0.0org.apache.druid.extensions:druid-basic-security:36.0.0

Affected Products

1 product · 1 configurations
Application
druidapache
≥ 0.17.0 && < 36.0.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.druid.extensions:druid-basic-security, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.druid.extensions:druid-basic-security to 36.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-23906 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Affected Products and Versions * Apache Druid * Affected Versions: 0.17.0 through 35.x (all versions prior to 36.0.0) * Prerequisites: * druid-basic-security extension enabled * LDAP authenticator configured * Underlying LDAP server permits anonymous bind                                                                                                                                                    Vulnerability Description An authentication bypass vulnerability exists in Apache Druid when using the druid-basic-security extension with LDAP authentication. If the underl
O3 Security · Impact-Aware SCA

Is CVE-2026-23906 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-23906: druid-basic Auth Bypass — Fixed in 36.0.0