CVE-2026-22777 is a high-severity (CVSS 7.5) CWE-93 vulnerability in comfy-cli. A fix is available for comfy-cli — see the affected versions and patch details below.
ComfyUI-Manager is Vulnerable to CRLF Injection in Configuration Handler
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-22777.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
comfy-cli🐍comfy-cliReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Vulnerability Type: CRLF Injection via ConfigParser
An attacker can inject special characters into HTTP query parameters to add arbitrary configuration values to the config.ini file. This can lead to security setting tampering or modification of application behavior.
Affected Users: Users running ComfyUI-Manager in environments where ComfyUI is configured with the --listen option to allow remote access.
CVSS Score: 7.5 (High)
Patches
Fixed in the following versions:
- 3.39.2 (v3.x branch)
- 4.0.5 (v4.x branch)
Sanitization logic was added to the write_config() function to remove CRLF and NULL characters from all string values.
Workarounds
If upgrading is not possible:
- Run ComfyUI-Manager only on trusted networks
- Block external access via firewall
- Run on localhost only without the
--listenoption
References
Credit
This vulnerability was reported by:
- 李存义 [email protected]
- D0n9 Li [email protected]
- Swings [email protected]
- Osword from SGLAB of Legendsec at Qi'anxin Group [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | comfy-cli | ≥ 4.0.0&&< 4.0.5 | 4.0.5pip install --upgrade 'comfy-cli==4.0.5' |
| 🐍PyPI | comfy-cli | all versions | 3.39.2pip install --upgrade 'comfy-cli==3.39.2' |
Affected Products
comfyui-managercomfyDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for comfy-cli, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update comfy-cli to 4.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-22777 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
How to detect CVE-2026-22777
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2026-22777 -u https://target- Template
- ComfyUI-Manager < 3.39.2 - CRLF Configuration Injection
- Severity
- high
- Impact
- Attackers can modify application configuration, potentially altering security settings or application behavior.
- Remediation
- This issue has been patched in versions 3.39.2 and 4.0.5.
Template by ProjectDiscovery nuclei-templates (TassioSales, DhiyaneshDk), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2026-22777 in your dependencies?
Find it across PyPI, including transitive dependencies.