NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2026-22748 — spring-security-oauth2-jo…

MEDIUM

CVE-2026-22748 is a medium-severity (CVSS 5.3) Improper Input Validation vulnerability in org.springframework.security:spring-security-oauth2-jose. A fix is available for org.springframework.security:spring-security-oauth2-jose — see the affected versions and patch details below.

Potential Security Misconfiguration when Using withIssuerLocation

Also known asGHSA-cvc6-q2cp-2xhw
Published
Updated
Affected
4 pkgs
Patched
2 / 4
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-22748.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs10th percentile — riskier than 10% of all scored CVEsHighest risk
0.00%0.23%0.47%0.70%0.1%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.springframework.security:spring-security-oauth2-jose☕org.springframework.security:spring-security-oauth2-jose☕org.springframework.security:spring-security-oauth2-jose☕org.springframework.security:spring-security-oauth2-jose

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Vulnerability in Spring Spring Security. When an application configures JWT decoding with NimbusJwtDecoder  or NimbusReactiveJwtDecoder, it must configure an OAuth2TokenValidator<Jwt> separately, for example by calling setJwtValidator. This issue affects Spring Security: from 6.3.0 through 6.3.14, from 6.4.0 through 6.4.14, from 6.5.0 through 6.5.9, from 7.0.0 through 7.0.4.

Affected Packages

4 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework.security:spring-security-oauth2-jose≥ 6.3.0No fix
☕Mavenorg.springframework.security:spring-security-oauth2-jose≥ 6.4.0No fix
☕Mavenorg.springframework.security:spring-security-oauth2-jose≥ 6.5.0&&< 6.5.106.5.10org.springframework.security:spring-security-oauth2-jose:6.5.10
☕Mavenorg.springframework.security:spring-security-oauth2-jose≥ 7.0.0&&< 7.0.57.0.5org.springframework.security:spring-security-oauth2-jose:7.0.5

Affected Products

1 product · 4 configurations
Application
spring securityvmware
≥ 7.0.0 && < 7.0.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.security:spring-security-oauth2-jose, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2026-22748; check the affected-versions list above or the advisory for the patched release of org.springframework.security:spring-security-oauth2-jose, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
Workaround published by Red Hat
To mitigate this issue, applications using Spring Security's `NimbusJwtDecoder` or `NimbusReactiveJwtDecoder` must explicitly configure an `OAuth2TokenValidator<Jwt>`. This ensures proper validation of JSON Web Tokens, preventing unauthorized access or data manipulation. Consult Spring Security documentation for correct implementation of `OAuth2TokenValidator<Jwt>` within your application's security configuration. A restart or reload of the affected application may be required for the changes to take effect.
Source: Red Hat security advisory for CVE-2026-22748 (CC BY 4.0)

Frequently Asked Questions

Vulnerability in Spring Spring Security. When an application configures JWT decoding with NimbusJwtDecoder  or NimbusReactiveJwtDecoder, it must configure an OAuth2TokenValidator<Jwt> separately, for example by calling setJwtValidator. This issue affects Spring Security: from 6.3.0 through 6.3.14, from 6.4.0 through 6.4.14, from 6.5.0 through 6.5.9, from 7.0.0 through 7.0.4.
O3 Security · Impact-Aware SCA

Is CVE-2026-22748 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-22748: spring-security-oauth2 — Fixed in 6.5.10