NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2026-21877 — n8n

CRITICALFix: n8n-io/n8n@f4b009d

CVE-2026-21877 is a critical-severity (CVSS 9.9) Code Injection vulnerability in n8n. A fix is available for n8n — see the affected versions and patch details below.

n8n is vulnerable to Remote Code Execution via Arbitrary File Write

Also known asGHSA-v364-rw7m-3263
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-21877.

EPSS Exploitation Probability

via FIRST.org ↗
5.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
2.59%7.33%12.1%16.8%14.1%5.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

36other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
n8nnpm
160Kdownloads / week

Description

Impact

n8n is affected by an authenticated Remote Code Execution (RCE) vulnerability.

Under certain conditions, an authenticated user may be able to cause untrusted code to be executed by the n8n service. This could result in full compromise of the affected instance.

Both self-hosted and n8n Cloud instances are impacted.

Patches

The issue has been resolved in n8n version 1.121.3.

Users are advised to upgrade to this version or later to fully address the vulnerability.

Workarounds

If upgrading is not immediately possible, administrators can reduce exposure by disabling the Git node and limiting access for untrusted users.

References

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmn8n≥ 0.123.0&&< 1.121.31.121.3npm install n8n@1.121.3

Affected Products

1 product · 1 configurations
Application
n8nn8n
≥ 0.123.0 && < 1.121.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for n8n, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update n8n to 1.121.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-21877 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

How to detect CVE-2026-21877

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2026-21877 -u https://target
Template
n8n >= 0.123.0 and < 1.121.3 - Remote Code Execution
Severity
critical
Impact
Full system compromise including access to all credentials, API tokens, OAuth secrets, database connections, and workflow automation capabilities. n8n becomes a single point of failure exposing all connected systems.
Remediation
Upgrade to n8n v1.121.3 or later. If upgrading is not immediately possible, disable the Git node and limit access for untrusted users.

Template by ProjectDiscovery nuclei-templates (s4e-io), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

### Impact n8n is affected by an authenticated Remote Code Execution (RCE) vulnerability. Under certain conditions, an authenticated user may be able to cause untrusted code to be executed by the n8n service. This could result in full compromise of the affected instance. Both self-hosted and n8n Cloud instances are impacted. ### Patches The issue has been resolved in n8n version 1.121.3. Users are advised to upgrade to this version or later to fully address the vulnerability. ### Workarounds If upgrading is not immediately possible, administrators can reduce exposure by disabling the Git
O3 Security · Impact-Aware SCA

Is CVE-2026-21877 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-21877: n8n RCE — Fixed in 1.121.3