NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2026-21858 — n8n

CRITICAL

CVE-2026-21858 is a critical-severity (CVSS 10) Improper Input Validation vulnerability in n8n. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for n8n — see the affected versions and patch details below.

n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling

Also known asGHSA-v4pr-fm98-w9pg
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
3 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-21858.

EPSS Exploitation Probability

via FIRST.org ↗
78.2%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
0.00%33.3%66.7%100.0%5.8%78.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

36other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
n8nnpm
138Kdownloads / week

Description

Impact

A vulnerability in n8n allows an attacker to access files on the underlying server through execution of certain form-based workflows. A vulnerable workflow could grant access to an unauthenticated remote attacker. This could result in exposure of sensitive information stored on the system and may enable further compromise depending on deployment configuration and workflow usage.

Patches

The issue has been fixed in n8n version 1.121.0. Users should upgrade to this version or later to remediate the vulnerability.

Workarounds

No official workarounds are available. As a temporary mitigation, users may restrict or disable publicly accessible webhook and form endpoints until upgrading.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmn8n≥ 1.65.0&&< 1.121.01.121.0npm install n8n@1.121.0

Affected Products

1 product · 1 configurations
Application
n8nn8n
≥ 1.65.0 && < 1.121.0
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for n8n, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update n8n to 1.121.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-21858 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

How to detect CVE-2026-21858

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2026-21858 -u https://target
Template
n8n Webhooks - Remote Code Execution
Severity
critical
Impact
Unauthenticated remote attackers can access sensitive files, potentially leading to information disclosure and further system compromise.
Remediation
Update to version 1.121.0 or later.

Template by ProjectDiscovery nuclei-templates (rxerium), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

### Impact A vulnerability in n8n allows an attacker to access files on the underlying server through execution of certain form-based workflows. A vulnerable workflow could grant access to an unauthenticated remote attacker. This could result in exposure of sensitive information stored on the system and may enable further compromise depending on deployment configuration and workflow usage. ### Patches The issue has been fixed in n8n version 1.121.0. Users should upgrade to this version or later to remediate the vulnerability. ### Workarounds No official workarounds are available. As a tempor
O3 Security · Impact-Aware SCA

Is CVE-2026-21858 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-21858: n8n — Fixed in 1.121.0