CVE-2026-18446 is a high-severity (CVSS 7.5) CWE-436 vulnerability in fast-uri. A fix is available for fast-uri — see the affected versions and patch details below.
fast-uri vulnerable to host confusion via backslash authority introducer
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-18446.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
fast-urinpmDescription
Impact
fast-uri v4.1.1 and earlier require a literal // to recognize a URI authority, so a reference that uses \\, /\, or \/ as the authority introducer (in place of //, after an optional scheme) is parsed with no authority: the sequence and everything after it fold into the path. Node's native WHATWG URL (used by fetch(), undici, and Node's http/https clients) instead treats \ as interchangeable with / for special schemes (http, https, ws, wss, ftp, file), so the two parsers extract different hosts from the same input.
For example, fast-uri resolves \\evil.com/path against base https://allowed.com/ to https://allowed.com/%5C%5Cevil.com/path (confined to the trusted host), while Node's WHATWG URL resolves the same reference to https://evil.com/path.
Applications that use fast-uri to enforce host-based policy (allowlists, denylists, loopback/SSRF filtering, redirect validation, outbound proxy routing) before passing the same URL into Node's URL or fetch() consumers see a policy/use desync and can be steered to an unintended destination.
Patches
Upgrade to fast-uri v4.1.2, v3.1.5, v2.4.4.
Workarounds
None. Upgrade to the patched version.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | fast-uri | all versions | 2.4.4npm install fast-uri@2.4.4 |
| 📦npm | fast-uri | ≥ 3.0.0&&< 3.1.5 | 3.1.5npm install fast-uri@3.1.5 |
| 📦npm | fast-uri | ≥ 4.0.0&&< 4.1.2 | 4.1.2npm install fast-uri@4.1.2 |
Affected Products
fast-uriopenjsfDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for fast-uri, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update fast-uri to 2.4.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-18446 is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This is an Important host confusion vulnerability in fast-uri, which can affect Red Hat products that use the library for URI parsing and security policy enforcement. The discrepancy in how fast-uri handles backslash-based URI authority introducers compared to Node.js's native URL parser can lead to bypasses of…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2026-18446 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Hardened Images | grafana13-1-main-13.1.1-0.4.hum1 | RHSA-2026:49387 |
| Red Hat Hardened Images | grafana12-4-main-12.4.6-0.3.hum1 | RHSA-2026:49401 |
| Red Hat OpenShift AI 2.25 | rhoai/odh-dashboard-rhel9:1791853525 | RHSA-2026:87410 |
| Red Hat OpenShift AI 3.4 | rhoai/odh-dashboard-rhel9:1791861020 | RHSA-2026:84734 |
| Red Hat OpenShift AI 3.4 | rhoai/odh-mod-arch-gen-ai-rhel9:1793001896 | RHSA-2026:92510 |
| Red Hat OpenShift Container Platform 4.16 | openshift4/ose-monitoring-plugin-rhel9:1788235712 | RHSA-2026:62550 |
| Red Hat OpenShift Container Platform 4.21 | openshift4/nmstate-console-plugin-rhel9:1789592806 | RHSA-2026:68547 |
| Red Hat OpenShift Container Platform 4.22 | openshift4/nmstate-console-plugin-rhel9:1789567849 | RHSA-2026:68553 |
Frequently Asked Questions
Is CVE-2026-18446 in your dependencies?
Find it across npm, including transitive dependencies.