NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2026-1774 — @casl/ability

CRITICALFix: stalniy/casl#1093

CVE-2026-1774 is a critical-severity (CVSS 9.8) vulnerability in @casl/ability. A fix is available for @casl/ability — see the affected versions and patch details below.

CASL Ability is Vulnerable to Prototype Pollution

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 25, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-1774.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk+0.06%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.41%0.81%1.22%0.0%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

602other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@casl/abilitynpm
1.5Mdownloads / week

Description

CASL Ability, versions 2.4.0 through 6.7.4, contains a prototype pollution vulnerability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@casl/ability≥ 2.4.0&&< 6.7.56.7.5npm install @casl/ability@6.7.5

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @casl/ability, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @casl/ability to 6.7.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-1774 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

CASL Ability, versions 2.4.0 through 6.7.4, contains a prototype pollution vulnerability.
O3 Security · Impact-Aware SCA

Is CVE-2026-1774 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-1774: @casl/ability — Fixed in 6.7.5