CVE-2026-1528 — undici
HIGHCVE-2026-1528 is a high-severity (CVSS 7.5) CWE-248 vulnerability in undici. A fix is available for undici — see the affected versions and patch details below.
undici is vulnerable to Malicious WebSocket 64-bit length overflows undici parser and crashes the client
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-1528.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
undicinpmDescription
Impact
A server can reply with a WebSocket frame using the 64-bit length form and an extremely large length. undici's ByteParser overflows internal math, ends up in an invalid state, and throws a fatal TypeError that terminates the process.
Patches
Patched in the undici version v7.24.0 and v6.24.0. Users should upgrade to this version or later.
Workarounds
There are no workarounds.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | undici | ≥ 6.0.0&&< 6.24.0 | 6.24.0npm install undici@6.24.0 |
| 📦npm | undici | ≥ 7.0.0&&< 7.24.0 | 7.24.0npm install undici@7.24.0 |
Affected Products
undicinodejsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for undici, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update undici to 6.24.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-1528 is resolved across your whole dependency graph.
Workarounds
Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2026-1528 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Cryostat 4 on RHEL 9 | cryostat/cryostat-openshift-console-plugin-rhel9:4.2.0-9 | RHSA-2026:17789 |
| Red Hat Enterprise Linux 10 | nodejs22-1:22.22.2-1.el10_1 | RHSA-2026:7080 |
| Red Hat Enterprise Linux 10 | nodejs24-1:24.14.1-2.el10_1 | RHSA-2026:7675 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | nodejs22-1:22.22.2-2.el10_0 | RHSA-2026:7310 |
| Red Hat Enterprise Linux 8 | nodejs:22-8100020260331102257.6d880403 | RHSA-2026:7123 |
| Red Hat Enterprise Linux 8 | nodejs:24-8100020260408131901.6d880403 | RHSA-2026:7670 |
| Red Hat Enterprise Linux 9 | nodejs:22-9070020260401095228.rhel9 | RHSA-2026:7302 |
| Red Hat Enterprise Linux 9 | nodejs:24-9070020260402152654.rhel9 | RHSA-2026:7350 |
Frequently Asked Questions
Is CVE-2026-1528 in your dependencies?
Find it across npm, including transitive dependencies.