CVE-2026-1525 — undici
MEDIUMCVE-2026-1525 is a medium-severity (CVSS 6.5) CWE-444 vulnerability in undici. A fix is available for undici — see the affected versions and patch details below.
undici is vulnerable to Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling')
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-1525.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
undicinpmDescription
Impact
Undici allows duplicate HTTP Content-Length headers when they are provided in an array with case-variant names (e.g., Content-Length and content-length). This produces malformed HTTP/1.1 requests with multiple conflicting Content-Length values on the wire.
Who is impacted:
- Applications using
undici.request(),undici.Client, or similar low-level APIs with headers passed as flat arrays - Applications that accept user-controlled header names without case-normalization
Potential consequences:
- Denial of Service: Strict HTTP parsers (proxies, servers) will reject requests with duplicate
Content-Lengthheaders (400 Bad Request) - HTTP Request Smuggling: In deployments where an intermediary and backend interpret duplicate headers inconsistently (e.g., one uses the first value, the other uses the last), this can enable request smuggling attacks leading to ACL bypass, cache poisoning, or credential hijacking
Patches
Patched in the undici version v7.24.0 and v6.24.0. Users should upgrade to this version or later.
Workarounds
If upgrading is not immediately possible:
- Validate header names: Ensure no duplicate
Content-Lengthheaders (case-insensitive) are present before passing headers to undici - Use object format: Pass headers as a plain object (
{ 'content-length': '123' }) rather than an array, which naturally deduplicates by key - Sanitize user input: If headers originate from user input, normalize header names to lowercase and reject duplicates
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | undici | all versions | 6.24.0npm install undici@6.24.0 |
| 📦npm | undici | ≥ 7.0.0&&< 7.24.0 | 7.24.0npm install undici@7.24.0 |
Affected Products
undicinodejsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for undici, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update undici to 6.24.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-1525 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Moderate impact. A flaw in the undici Node.js HTTP/1.1 client allows for HTTP Request Smuggling or Denial of Service. This can occur in Red Hat products that use undici and process HTTP requests where user-controlled header names are not case-normalized, or headers are passed as flat arrays.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2026-1525 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Cryostat 4 on RHEL 9 | cryostat/cryostat-openshift-console-plugin-rhel9:4.2.0-9 | RHSA-2026:17789 |
| Red Hat Enterprise Linux 10 | nodejs22-1:22.22.2-1.el10_1 | RHSA-2026:7080 |
| Red Hat Enterprise Linux 10 | nodejs24-1:24.14.1-2.el10_1 | RHSA-2026:7675 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | nodejs22-1:22.22.2-2.el10_0 | RHSA-2026:7310 |
| Red Hat Enterprise Linux 8 | nodejs:22-8100020260331102257.6d880403 | RHSA-2026:7123 |
| Red Hat Enterprise Linux 8 | nodejs:24-8100020260408131901.6d880403 | RHSA-2026:7670 |
| Red Hat Enterprise Linux 9 | nodejs:22-9070020260401095228.rhel9 | RHSA-2026:7302 |
| Red Hat Enterprise Linux 9 | nodejs:24-9070020260402152654.rhel9 | RHSA-2026:7350 |
Frequently Asked Questions
Is CVE-2026-1525 in your dependencies?
Find it across npm, including transitive dependencies.