NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2026-1513 — billboard.js

MEDIUMFix: naver/billboard.js@49e079c

CVE-2026-1513 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in billboard.js. A fix is available for billboard.js — see the affected versions and patch details below.

billboard.js is vulnerable to XSS during chart option binding

Also known asGHSA-rpc5-pm7q-hjmp
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-1513.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs11th percentile — riskier than 11% of all scored CVEsHighest risk
0.00%0.24%0.47%0.71%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

51other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
billboard.jsnpm
65Kdownloads / week

Description

billboard.js before 3.18.0 allows an attacker to execute malicious JavaScript due to improper sanitization during chart option binding.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmbillboard.jsall versions3.18.0npm install billboard.js@3.18.0

Affected Products

1 product · 1 configurations
Application
billboard.jsnaver
< 3.18.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for billboard.js, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update billboard.js to 3.18.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-1513 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

billboard.js before 3.18.0 allows an attacker to execute malicious JavaScript due to improper sanitization during chart option binding.
O3 Security · Impact-Aware SCA

Is CVE-2026-1513 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-1513: billboard.js — Fixed in 3.18.0