CVE-2026-0895 — typo3-mailqueue
Fix: CPS-IT/mailqueue@12a0a35CVE-2026-0895 is a Deserialization of Untrusted Data vulnerability in cpsit/typo3-mailqueue. A fix is available for cpsit/typo3-mailqueue — see the affected versions and patch details below.
Insecure Deserialization in extension "Mailqueue" (mailqueue)
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-0895.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
cpsit/typo3-mailqueue🐘cpsit/typo3-mailqueueReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Description
The extension extends TYPO3’s FileSpool component, which was vulnerable to Insecure Deserialization prior to TYPO3-CORE-SA-2026-004. Since the related fix is overwritten by the extension, using the extension with a patched TYPO3 core version still allows for Insecure Deserialization, because the affected vulnerable code was extracted from TYPO3 core to the extension.
More information about this vulnerability can be found in the related TYPO3 Core Security Advisory TYPO3-CORE-SA-2026-004.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | cpsit/typo3-mailqueue | all versions | 0.4.3composer require cpsit/typo3-mailqueue:^0.4.3 |
| 🐘Packagist | cpsit/typo3-mailqueue | ≥ 0.5.0&&< 0.5.1 | 0.5.1composer require cpsit/typo3-mailqueue:^0.5.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cpsit/typo3-mailqueue, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update cpsit/typo3-mailqueue to 0.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-0895 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is CVE-2026-0895 in your dependencies?
Find it across Packagist, including transitive dependencies.