CVE-2025-9341 — bc-fips
CVE-2025-9341 is a Uncontrolled Resource Consumption vulnerability in org.bouncycastle:bc-fips. A fix is available for org.bouncycastle:bc-fips — see the affected versions and patch details below.
Garbage collection can delay for AES CBC Native support, resulting in heap exhaustion
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-9341.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.bouncycastle:bc-fips☕org.bouncycastle:bctls-fipsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Uncontrolled Resource Consumption vulnerability in Legion of the Bouncy Castle Inc. Bouncy Castle for Java FIPS bc-fips on All (API modules), Legion of the Bouncy Castle Inc. Bouncy Castle for Java LTS bcprov-lts8on on All (API modules) allows Excessive Allocation. This vulnerability is associated with program files org/bouncycastle/crypto/fips/AESNativeCBC.Java, org/bouncycastle/crypto/engines/AESNativeCBC.Java.
This issue affects Bouncy Castle for Java FIPS: 2.1.0; Bouncy Castle for Java LTS: from 2.73.0 through 2.73.7.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.bouncycastle:bc-fips | ≥ 2.1.0&&< 2.1.1 | 2.1.1org.bouncycastle:bc-fips:2.1.1 |
| ☕Maven | org.bouncycastle:bctls-fips | ≥ 2.73.7&&< 2.73.8 | 2.73.8org.bouncycastle:bctls-fips:2.73.8 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.bouncycastle:bc-fips, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.bouncycastle:bc-fips to 2.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-9341 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2025-9341 in your dependencies?
Find it across Maven, including transitive dependencies.